the dc7700 just don't do linux

 
Mogens Kjaer
Frequent Advisor

Re: the dc7700 just don't do linux

I had to boot with acpi=off and noapic in order
to run a 2.6.19 kernel on a dc7700

BTW, I got the NIC to work with a newer e1000
driver than the one included in Fedora 6.
Mogens Kjaer
Frequent Advisor

Re: the dc7700 just don't do linux

One funny thing:

I've tried booting the HP Insight Diagnostics,
version 7.7.0 A on this machine (this
CD is Linuxbased).

It doesn't!

If I raise loglevel to 9, I get the usual
kernel messages during boot, and it hangs
at the same place as my Fedora boot:

ACPI: Assume root bridge [\_SB_.PCI0] bus is 0

I can boot the CD if I add acpi=off

So the machine fails diagnostics :-)
Steven E. Protter
Exalted Contributor

Re: the dc7700 just don't do linux

Shalom,

Its pretty clear Linux should NOT be used on this box.

If you want support you should probably contact HP and demand it. This is typical of entry level HP computers though its mostly laptops with this problem that I've seen in ITRC.

Truth in advertising there is nothing on the HP website saying anything different.

Before you buy, look for the penguin.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Florian Heigl (new acc)
Honored Contributor

Re: the dc7700 just don't do linux

i think pci=1 should change the irq routing, which would appear reasonable.

I'll save You the rant over broken BIOSses being delivered. But I can't share the 'support' reasoning at all - if You buy a PC You should get a PC that adheres to standards to some extent.
yesterday I stood at the edge. Today I'm one step ahead.
awa
New Member

Re: the dc7700 just don't do linux

My dc7700 is running SuSE 10.1 very well
The installation was smooth. I used the boot CD to perform a resize of the NTFS partition, repartition the disk and finally install on new partitions.
The only issue is with the sound system. but this seems to be fixed by using ALSA.
To be honnest I must add that neither knoppix nor gparted were able to boot. Both distro had a kernel hang-up during the PCI probe step. Fixed with SuSE :-)
BryanJ
New Member

Re: the dc7700 just don't do linux

Would someone who got the sound to work with the DC7700 and Linux using ALSA care to share how they did it? I'm running SuSE Enterprise Linux Desktop 10.1 and I haven't been able to get the sound to work. Other than that, it has been running flawlessly using the acpi settings previously mentioned in this thread.

Thanks,

Bryan
NancyITadmin
Occasional Advisor

Re: the dc7700 just don't do linux

While investigating the use of Linux on DC7700 desktops I got this response back from presales support indicating that installing / running Linux on dc7700 desktops was not really a problem.

--------- Forwarded message ----------
From: Presales_Support
Date: Jan 25, 2007 11:44 AM
Subject: HP
To: Nancy

Dear Nancy

Thank you for contacting Hewlett-Packard and for being a valued HP
customer.

HP offers a number of solutions for our business customers and hopefully
we will be able to fully meet your needs. We do have support for Linux
through our business desktops. We currently do not offer any
pre-configured desktops in the HP Compaq dc7700 line. We do offer a
version with free DOS that will allow you to add Linux without the need
for purchasing Windows when you do not need it.

We do have a direct Linux hotline available to customers such as
yourself. I would recommend contacting our HP Linux Hotline associates
directly at 1-888-HP-LINUX and they will be glad to assist you further.
You can also send them a contact request by filling out a contact
request form at the following web site:

http://h71028.www7.hp.com/enterprise/cache/328202-0-0-0-121.html

For future purchases you may buy directly from Hewlett-Packard, at the
HP Small & Medium Business Sales Center. You can log on at:

http://www.hp.com/buy/smb

You may also call 1-800-888-9909.

To locate a Hewlett-Packard authorized reseller(s) in your area, please
visit our web site at:

http://hp.via.infonow.net/locator/us_partner/index.jsp

I hope I have thoroughly answered all of your presales questions.
Please reply to this message if we can be of further assistance.

For your convenience, you can also call our Presales Department at
1-800-752-0900 (8:30am - 8:30pm, Mon-Fri, and 10am - 7pm Sat, Eastern
Time). Our Hewlett-Packard representatives are trained professionals
who can help you decide on the right HP product for you.

Once again, thank you for your interest in Hewlett-Packard products. We
value your business!


Sincerely,

David Hoop
Representative
Hewlett-Packard
NancyITadmin
Occasional Advisor

Re: the dc7700 just don't do linux


Dear Linux friends,

It seems that when I called HP presales back in order to discuss their incorrect statement in above forum posting all of a sudden this forum posting disappeared when I pointed out the reality to them.

As such, I have tried to repost with another account.

Nancy

NancyITadmin
Occasional Advisor

Re: the dc7700 just don't do linux

As my upper management is angry about the lost time and the still +10 idle machines, I needed to proceed to get things rolling with HP

My latest response from HP, and the first that actually is correct and acknowledges the problems.

May this can help above poster to get the sound working ?

nancy

im Chambers Thu, Feb 22, 2007 at 6:04 AM
To: Nancy B
Cc: presales_support@mail.support.hp.com, oslo.helpcustomers@lists.hp.com
Nancy,

You have reached the team who specializes in addressing Linux problems
raised by customers who write to HP. I am a program manager and
experienced software engineer, not a helpdesk responder.

I have been investigating this issue and obtained the following
information from my contact from the dc7700 product group.

When Red Hat releases RHEL 5.0, the dc7700 will not be certified, but
it will install on the machine. There are some visible bugs which you
can work around. These are:

1. RHEL 5.0 will only install if the kernel flag 'acpi=off' is
supplied at boot time (either by the user, or permanently set in
/etc/grub.conf)

2. The accelerated graphics driver from Intel has a serious bug which
causes the display to become unreadable if you switch to a tty.
If this happens, the only remedy is to reboot the machine. If you
change your video driver to vesa, the situation is a bit better
because you can fix the problem simply by bringing the machine
down to runlevel 3 and then back up to runlevel 5. It's best if
you never switch to a standard tty to begin with.

3. Audio plays only out of the front jacks. This should be fixed in
the next version of ALSA (1.0.14rc3) but you would have add that
to the system on your own.

http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=1081719
also has some information about Linux on the dc7700 that you might
find useful. (Try booting with "pci=conf1".)

If I have not addressed your concerns, you can reply to this message
and our Linux team at oslo.helpcustomers@lists.hp.com will make an
effort to assist you. Please understand that because Red Hat will not
be certified on the dc7700, your configuration is not officially
supported by HP. Therefore, we can only make a "best effort" to
help. I regret the imprecision of David's choice of words.

--
tim chambers
program manager
on behalf of the oslo.helpcustomers@lists.hp.com team
hp open source & linux organization (oslo)
catarina_2
New Member

Re: the dc7700 just don't do linux

Hi,

I have the same problem on a fresh DC7700pC with :
- Processeur Intel Core 2 Duo E6300
- Chipset Intel 965Q Express
- LAN Intel 82566DM Gigabit

I understand than Maarten Verwijs said that kernel 'must' be at least '2.6.19' to work on.
He said also "The Knoppix method will work on DC7700 when Knopper releases a knoppix cd with 2.6.19 kernels"
Now, the Knoppix 5.1.1 has kernel 2.6.19.1

Must I use the 'all' method, or it is a simplest way to obtain a basic linux box (any distro) to act as devel server (ie. install Knoppix on HD) ?

I have tried only Centos 4.3 and RHEL 4.0 at this time and search for distro with 2.6.19+ kernel 'in case of ...'; any suggestion ?

Thank