the dc7700 just don't do linux

 
Gerjan Teselink
New Member

Re: the dc7700 just don't do linux

I'm running DC7700 with Linux since December. To be honest it was hell to setup the machine for the first time.

The only difficulty I had was the limitation of only 1Gb RAM. This is solved with bios version 2.09.

I've customized the FreeDOS image and aded the MEFlash program and the DOSFlash program.

If you want to run MEFlash under Freedos you have to run Freedos without himem.sys and emm386.

Currently I run the 2.6.20.1 kernel with ACPI at kernel level disabled.

A basic configurationfile of the 2.6.20.1 kernel is attached.
Donpicoro
New Member

Re: the dc7700 just don't do linux

We were able to install slackware linux on those machines. I post everything as complete as possiblein here:

http://www.gfnun.unal.edu.co/indexX.php?pagina=hpdc7700&idioma=english


hope it helps.
Xavier Gutierrez_2
Frequent Advisor

Re: the dc7700 just don't do linux

Folks,

I was able to boot the RHEL4 CDROM with the following options:

acpi=off pci=confl nousb

Cheers,

X.-
Mogens Kjaer
Frequent Advisor

Re: the dc7700 just don't do linux

Fedora 7, test 4, x86_64 seems to work
with the dc7700 without any extra kernel
options.
dannyb_1
Occasional Advisor

Re: the dc7700 just don't do linux

Hi everybody,
I have at work several machines like this. We tried using RedHat 4 Enterprise with no success. Fedora 6 worked with the already known workarounds like pci=nommconf, but it still had strange problems related to Video Graphic Adapter and Network. We got strange small hiccups if I ran glxgears, but If I have restarted the network daemon it was working correctly.
With Fedora 7 it installed ok, but the problems continues. Same hiccups with Video driver (even if it has the intel proprietary now), but now if I restart the network, the keyboard won't work.
My conclusion is that there are weird conflicts on hardware sharing, and I was not able to fix them. Sometimes unloading the e1000 driver and replacing it with e100 driver seems to work.
With the latest xorg updates from today, I don't have any hiccups in the system, but the graphics adapter still has problems.
We are going to change these machines with something else next week. It's ashame.
dannyb_1
Occasional Advisor

Re: the dc7700 just don't do linux

After the latest updates from in F7 I don't have any more interrupts when moving the mouse on the screen.
More, I have found a way to make glxgears (opengl applications to run without interruptions).
- service network stop
- rmmod e1000
- modprobe e100
- service network stop

It seems that somehow the e1000 driver is having a conflict with the video adapter. Removing it and using e100 solves the problem.

Good luck
ionut_lascu
Advisor

Re: the dc7700 just don't do linux

What kernel version suport hdparm ?
HPQ HPQ
New Member

Re: the dc7700 just don't do linux

Some Linux distributions OpenSUse 10.2 have a problem partitioning hard drive because some dc7700p systems have two hard-drives in RAID configuration. Installation fails. So, do not buy any configuration that has RAID config.

You can go to BIOS and disable RAID and attempt to install Linux on the second hard-drive. OpenSUSE 10.2 partitioning process still fails. The partitioning seems alright, but I think the failure occurs when the file system gets created.

You can install by having only one hard-drive in the entire system. Unplug the Windows hard-drives.

Intel Q965/Q963 driver does not work in Linux. If you only want 1280x1024 configuration in Linux, this is no problem because it uses frame-buffers and not the graphics adapter itself (basically Q965 is useless). You have to buy some other video card to get higher resolutions.

Bottomline: If you want to run Linux, this system not a good choice. There are many other machines or vendors that offer a much smoother solutions for Linux. If you want to dual-boot with Windows, this machine is next to useless. You never know if the future Linux versions will be compatible with the hardware.

Going forward, there will be no more HP system purchases from me for my business if I need to run Linux or dual-boot. For such systems, I am going to a vendor that sells Linux preinstalled (OpenSuse specifically). Certification is not enough. I would like full pre-installation and full business-class support.

Gerjan Teselink
New Member

Re: the dc7700 just don't do linux

A few remarks:

support for hdparm is since the 2.0 kernel.

Then the previous poster. I absolutly don't agree with you about the poor support of OpenSuse with de DC7700. Most software raids work poor in linux (not only driver-support but also performance) Therefor are good alternatives.

I installed at about 20+ DC7700 machines with Linux and I only had to put off ACPI (which I post before).

Kind regards,

Gerjan
Steven E. Protter
Exalted Contributor

Re: the dc7700 just don't do linux

Well Gerjan,

You might want to share your secrets in detail.

When we contacted HP Israel about Linux and the dc7700 system, their response was to tell us to buy another platform.

The dc7700 has no HP support for running Linux. Nor does Red Hat support his platform.

I reiterate my earlier commentary which is to not use Red Hat or any other Linux on this hardware until HP provides offical support. That is Corporate policy where I work as well.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com