cancel
Showing results for 
Search instead for 
Did you mean: 

tomcat

Piotr Kirklewski
Super Advisor

tomcat

Hi there
I did:

Urpmi Tomcat5
urpmi tomcat5-webapps
urpmi tomcat5-admin-clearwebapps


I get apache webpage http://localhost but nothing on http://localhost:8080


netstat -anp |grep 8080

tcp 0 0 :::8080 :::* LISTEN 5710/java


Firewall is off.


Any ideas ?


Jesus is the King
5 REPLIES
Marco A.
Esteemed Contributor

Re: tomcat

Hmm .., seems to be that you have another 8080 application running there.

tcp 0 0 :::8080 :::* LISTEN 5710/java


Did you check the apache configuration for for the port binding ?

If you run only netstat -anp |grep 80 , what's the output?

I think that apache is running at 80 now, I don't know.. just a thought.

Try that, maybe it works by changing the configuration at that file.

Regards,

Marco,
Just unplug and plug in again ....
B. Hulst
Trusted Contributor

Re: tomcat

Open ports you see with:
netstat -lptu
or

lsof -i | grep 8080



Or try tomcat first on another port 8081 for example.
Marco A.
Esteemed Contributor

Re: tomcat

The lsof option is really good.

If you don't have it .., take it from here

http://hpux.connect.org.uk/hppd/hpux/Sysadmin/lsof-4.81/

Regards,

Marco,
Just unplug and plug in again ....
dirk dierickx
Honored Contributor

Re: tomcat

he's obviously running linux, no need to get the hpux lsof. lsof is probaly already installed by default on linux, or else it's just one command to install it.
Rick Retterer
Respected Contributor

Re: tomcat

# /sbin/service tomcat5 status

Check the file: /var/log/tomcat5/catalina.out

Make sure that you don't have any errors.

You can stop/restart tomcat5 like this:

# /sbin/service tomcat5 stop
{wait for process rundown}
# /sbin/service tomcat5 start

-then-

Check the following file:

/etc/tomcat5/server.xml

make sure that the following section is uncommented like this:


maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
enableLookups="false" redirectPort="8443" acceptCount="100"
connectionTimeout="20000" disableUploadTimeout="true" />


Then access the default Tomcat5 site:

http://hostname.domain.name.com:8080/


Those are some things to check.


- Rick Retterer