Simpler Navigation coming for Servers and Operating Systems
Coming soon: a much simpler Servers and Operating Systems section of the Community. We will combine many of the older boards, and you won't have to click through so many levels to get at the information you need. If you are looking for an older board and do not find it, check the consolidated boards, as the posts are still there.
cancel
Showing results for 
Search instead for 
Did you mean: 

udt generates SIGBUS core error

SOLVED
Go to solution

udt generates SIGBUS core error

Hi,
I have an HP_UX 11.0 box that is running unidata 5.1. It has been trouble free for over a year. This last week it has started generating core files and throwing users out of the db. file core > core: core file from 'udt' - received SIGBUS. db folks had me increase semmni parmameter to 96 (was 64). Recompiled kernel and rebooted. Still getting the errors.
Thanks,
Rocky Lavoie
3 REPLIES
Tim Adamson_1
Honored Contributor
Solution

Re: udt generates SIGBUS core error

Hi Rocky,

You may still be hitting some kernel parameter limit. Can you post your /stand/system file and tell us what sort of server you have and the amount of RAM. Some folks here might be able to nail it if it is a kernel related problem.


Cheers!
Yesterday is history, tomorrow is a mystery, today is a gift. That's why it's called the present.

Re: udt generates SIGBUS core error

Hi,
I have an HP 9000 L2000 with 2G ram running 11.0 64bit RP5450. /stand/system file attached.
Tim Adamson_1
Honored Contributor

Re: udt generates SIGBUS core error

Hi Rocky,

I would contact the application vendor (UNIDATA) and ask them to check out the core file. Get them working on the problem too :-)

Without knowing your environment, so take the suggestions with a grain of salt, I would tune a few things:

dbc_max_pct 20 (any value from 10 to 20). Don't let buffer cache have too much cuz it never appears to give it back.

maxfiles appears a little low

maxuprc appear a little low

nfile looks too high based on your other settings, so perhaps drop it to 8000 (even then I would think it would be too high)

semmni is usually defined as (nproc*2). Give it a bit more. Obviously don't go overboard. Start with 512. You may need to change other related parameters too, such as semmns. Don't be afraid to do so.

Remember, if it all goes bad, you can always boot from the previous kernel by interrupting the boot process and interacting with the ISL. Then type "hpux /stand/vmunix.prev"


Cheers!!


Yesterday is history, tomorrow is a mystery, today is a gift. That's why it's called the present.