cancel
Showing results for 
Search instead for 
Did you mean: 

ulimit setting

ng_7
Regular Advisor

ulimit setting

hi, experts,

I would like to increase my data and stack limit to 3.8 GB. What I did was change maxdsiz and maxdsix_64bit from 2GB to 3.8GB (old and new setting as per attached)

after restart server, I notice my data limit is as below
ulimit -aH
time(seconds) unlimited
file(blocks) unlimited
data(kbytes) 4292870144
stack(kbytes) 262144
memory(kbytes) unlimited
coredump(blocks) unlimited
nofiles(descriptors) 2048

and ulimit -aS is
time(seconds) unlimited
file(blocks) unlimited
data(kbytes) 4292870144
stack(kbytes) 262144
memory(kbytes) unlimited
coredump(blocks) 4194303
nofiles(descriptors) 2048

is it something is wrong ? I also tried to set to 3GB but I get the below error

ulimit -d 3145728
su: ulimit: The specified value exceeds the user's allowable limit.

please advise what is the problem
thanks

11 REPLIES
Venkatesh BL
Honored Contributor

Re: ulimit setting

Can you post the "chatr " output? If your application is 'myapp', post output of "chatr ./myapp"
johnsonpk
Honored Contributor

Re: ulimit setting

Hi ,

>>ulimit -d 3145728
su: ulimit: The specified value exceeds the user's allowable limit.

The system wide stack is only 256 MB and allowable maximum value for stack ulimit command is 256MB
You may need to change the system wide stack according to your requirement by changing the kernel parameters maxssize and maxssize_64bit



thanks!!
Johsnon
johnsonpk
Honored Contributor

Re: ulimit setting

Ooops..apologize for the wrong post ...

please ignore the previous post ..

Thanks!!
Johnson
ng_7
Regular Advisor

Re: ulimit setting

1.
Can you post the "chatr " output? If your application is 'myapp', post output of "chatr ./myapp"

I not sure what you mean, this is my Oracle Application Server, so what should I type.


2. hi, Johnson,

is the below post is the wrong one ?

>>ulimit -d 3145728
su: ulimit: The specified value exceeds the user's allowable limit.

The system wide stack is only 256 MB and allowable maximum value for stack ulimit command is 256MB
You may need to change the system wide stack according to your requirement by changing the kernel parameters maxssize and maxssize_64bit


johnsonpk
Honored Contributor

Re: ulimit setting

Hi its apply to stack size ..since you have problem with data (ulimit -d) my post is not valid.

By the way ,try changing the softlimit

ulimit -Sd 3145728


>>ulimit -Hd 31400
su: ulimit: The specified value exceeds the user's allowable limit

I saw this kind of error some time ,when I tried to execute ulimit -Hd

what i did is change it with ulimit -Sd 31400
and then executed ulimit -Hd 31400

To increase the stack size you may need to tune the kernel parameters as i said in the previous post


Thanks!!
Johnson


Thanks!!
Johnson


ng_7
Regular Advisor

Re: ulimit setting

hi, I need your solution urgently,

why my data become so big

data(kbytes) 4292870144

after I increase my maxdsiz_64bit and maxdsiz to 3.8GB ?

is this correct ? I tried to set

ulimit -d 3145728 but get the below error
su: ulimit: The specified value exceeds the user's allowable limit.

thanks
Patrick Wallek
Honored Contributor

Re: ulimit setting

I bet you went an order of magnitude too high when you set the kernel parameter.

What value did you use for maxdsiz and maxdsiz_64?
johnsonpk
Honored Contributor

Re: ulimit setting

Hi ,

The maxssiz & maxssiz_64bit are in bytes on kernel and ulimit give out put in kilobytes


can you post kmtune|grep -e "maxd" -e "maxs"


did you try to reduce it by ulimit -Sd ?


Thanks!!!
Johnson
ng_7
Regular Advisor

Re: ulimit setting

thanks for your quick reply, I want to increase data and stack. the data is 2GB and stack is about 250mb, after I change the kernel
maxdsiz and maxdsiz_64bit to 3.5GB
and maxssiz to 400mb and maxssiz_64bit to 1GB ,

the ulimit -aH give output

data(kbytes) 4292870144
stack(kbytes) 392192

please see below for your requested info :

app:/# kmtune|grep -e "maxd" -e "maxs"
maxdsiz 3500000000 - 3500000000
maxdsiz_64bit 3500000000 - 3500000000
maxssiz 401604608 - 401604608
maxssiz_64bit 1073741824 - 1073741824
ng_7
Regular Advisor

Re: ulimit setting

my HP-UX version

HP-UX tamcoapp B.11.11 U 9000/800 1725937685 unlimited-user license

is anyone know my problem ?
Dennis Handly
Acclaimed Contributor

Re: ulimit setting

>anyone know my problem?

Your maxdsiz* and maxssiz* seem to be changed.
Now just run your application and ignore bogus values from ulimit.

>maxssiz to 400mb

This is way too big. You have reduced maxdsiz for default 32 bit apps to 600 Mb.