General
cancel
Showing results for 
Search instead for 
Did you mean: 

umount fails on reboot/shutdown.

Jonas Kvinge
Occasional Advisor

umount fails on reboot/shutdown.

On openSUSE 11.1 with KDE 3.5 I noticed that it did not successfully umount /var, /home and /usr upon reboot or shutdown.

I'm getting error such as: umount: /dev/sda9 busy

I edited /etc/rc.d/boot.localfs and entered lsof > /var/log/openfiles.txt after the line "if test "$UMOUNT_FAILED" = true -a -z "$mtab" ; then" to figure out what files were open.

I found that the programs console-kit-daemon, pulseaudio and dcopserve were still running.

I then entered the following before the umount lines:

killall -q -TERM console-kit-daemon
killall -q -TERM pulseaudio
killall -q -TERM dcopserve
sleep 1
killall -q -KILL console-kit-daemon
killall -q -KILL pulseaudio
killall -q -KILL dcopserve

It now successfully umount's all filesystems, but why are these programs still running, is it known problems or something wrong with my configuration?

Here is the disk partitions:

Filesystem Size Used Avail Use% Mounted on
/dev/sda5 3.0G 224M 2.6G 8% /
udev 1001M 2.1M 999M 1% /dev
/dev/sda1 595M 30M 535M 6% /boot
/dev/sda6 595M 83M 482M 15% /tmp
/dev/sda8 2.0G 296M 1.6G 16% /var
/dev/sda9 20G 4.9G 14G 26% /usr
/dev/sda10 5.0G 998M 3.7G 21% /opt
/dev/sda11 5.0G 139M 4.6G 3% /usr/local
/dev/sda12 73G 6.1G 63G 9% /home
/dev/sdb1 294G 251G 31G 90% /mnt/datadisk1
/dev/sdc1 233G 99G 135G 43% /mnt/datadisk2

2 REPLIES
Matti_Kurkela
Honored Contributor

Re: umount fails on reboot/shutdown.

Those processes all look like things that might be started by a local X session. They are daemons in the traditional Unix sense, but on the other hand, they are related to your session.

Exactly how did you perform the shutdown?
Did you use the "shutdown" command from the command line? If so, try using the shutdown button in the KDE logout dialog instead. (If the shutdown button is not displayed by default, adjust the KDE settings in the KDE Control Center).

When you use the shutdown button in the KDE logout dialog, KDE will first log you out, ending all the processes started for your session, and only then initates the shutdown. This should make sure all the "session-specific daemons" are stopped properly.

MK
MK
Jonas Kvinge
Occasional Advisor

Re: umount fails on reboot/shutdown.

I used the shutdown from KDE, I've also tried to logout to console and then shutdown. And I've tried to set the runlevel to 3 and not start X at all, atleast one of those programs are running also without starting X/KDE.