General
cancel
Showing results for 
Search instead for 
Did you mean: 

unicode... command not found

Ray Labahn
Occasional Visitor

unicode... command not found

I install a very slender version of RedHat Linux since we access remote sites via modem, sometimes at 9600 BAUD, and a graphical interface at that speed is miserable (final product is RainingData's D3 programs with D3 running as an application on Linux). Installing RedHat 9.0 with this 'slender' installation (around 600 Mb) results in error messages like 'unicode_start command not found' and likewise for '_stop'. These messages only show up on the console which is usually stuck away in some computer room and rarely observed after installing in the customers site. The message seems to cause no problems except its appearance is embarrising when the customer sees it and wonders what it means and we can only say, "We have not idea but no one has died from it so far". What module of modules does one have to install to get rid of this message? I am putting all RPMs onto the Linux partition so that I can 'fix' the problem after the sysems are installed.
6 REPLIES
Martin P.J. Zinser
Honored Contributor

Re: unicode... command not found

Well since you do not seem to need it, how about disabeling this service for the runlevels you use? I am not a Redhat person, but the scripts will be in /etc/init.d and there certainly will be a graphical tool to enable/disable service on a per runlevel basis.
Stuart Browne
Honored Contributor

Re: unicode... command not found

The 'unicode_start' and 'unicode_stop' routines are provided by the package 'kbd', and are to allow unicode fonts and applications to run on the console of a Linux box.

I'm unsure where these are called from (not able to find them on the 10 sec look at the RH8 & 9 boxes here, but somehow related to '/etc/init.d/keytable'), but you should be able to get rid of the message by installing this package.

It's dependancy table is pretty simple, so you shouldn't have to install anything else.
One long-haired git at your service...
Huc_1
Honored Contributor

Re: unicode... command not found

I had a look on my system's but found nothing contained unicode

"grep -i "unicode" /etc/init.d

revealed nothing on my RH 9.0 system (this has many things started)

but I thing the following may futher help you

man unicode
man utf-8
and
cat /etc/sysconfig/i18n

The above file could in your case define to utf and this could be remplaced by unicode.

But beware this will could change a lot of your font display on console

In a few words not sure but check this could help you out.

J-P ( please do not forget to assign points tks. )

Smile I will feel the difference
Karsten Breivik_1
Frequent Advisor

Re: unicode... command not found

There seems to be a problem with Unicode chars when installing RH with support for languages other than US english. I have installed norwegian support and get garbled man pages...

Perhaps this could be related to your problem. The workaround that works for me is to make sure my /etc/sysconfig/i18n file has

LANG="en_US"

in it instead of

LANG="something no_bokmal"

See the related URL: http://www.aplawrence.com/Bofcusm/1840.html

poi

Re: unicode... command not found

Because you did a 'slender' installation you probably used "Select Individual Packages" and just like I do (and did) uncheck anything you don't recognize.

you need to make sure the package "kbd" is installed.

From faqs.org's website:

http://www.faqs.org/docs/linux_scratch/chapter06/kbd.html

6.43.3. Contents of Kbd
Last checked against version 1.06.

6.43.3.1. Program Files
chvt, deallocvt, dumpkeys, fgconsole, getkeycodes, getunimap, kbd_mode, kbdrate, loadkeys, loadunimap, mapscrn, openvt, psfaddtable (link to psfxtable), psfgettable (link to psfxtable), psfstriptable (link to psfxtable), psfxtable, resizecons, setfont, setkeycodes, setleds, setlogcons, setmetamode, setvesablank, showfont,
showkey, unicode_start, and unicode_stop
----------------^ ------------^

Now if I could just figure out which package I didn't install that makes my command prompt say -bash-2.05b# instead of [root@hostname]#
There's No Place like root# cd ~/

Re: unicode... command not found

kbd is also apparently where the font latarcyrheb-sun16 is located, and for some reason, after i fixed the problem as I described before, logging in created the error "findfont [cannot locate latarcyrheb-sun16]" or similar error. This happened until I installed console-tools and then reinstall kbd. I can't guarantee that this was what fixed the problem since I also installed anything that said "Font" in the RPMS directory and then did a rpm -Uvh to kbd again.
There's No Place like root# cd ~/