Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

unsatisfied symbols:

Rich_20
Occasional Visitor

unsatisfied symbols:

We upgrated our HP-UX from 10.20 to 11.00 recently. When I try to recompile my Oracle application, I have a unsatisfied symbols. Here is error:

/usr/ccs/bin/ld: Unsatisfied symbols:
SQLCODE (data)
SQLCA (data)

This application has no problem when we use HP-UX 10.20. I checked the library path on 11.0, but couldn't find anything wrong.
This problem happens on both Oracle 7.4.3 and Oracle 8.1.7 clients.
Please help!

Thanks

Rich
3 REPLIES
harry d brown jr
Honored Contributor

Re: unsatisfied symbols:

Rich,

When you say upgraded, I hope you mean you did a fresh install of 11.00. Did you install the 32bit or the 64bit? How did you install oracle?

live free or die
harry
Live Free or Die
Wodisch
Honored Contributor

Re: unsatisfied symbols:

Hello Rich,

the HP-UX10.20 versions of Oracle do not work under HP-UX11.xx - you need to install the Oracle-versions for HP-UX11.xx :-(
Especially the networking part never did work, and even tough you might be able to start the (local) RDBMS background and server processes, they are NOT supported that way (well, AFAIK).

Just my $0.02,
Wodisch
Rich_20
Occasional Visitor

Re: unsatisfied symbols:

Basically, some other folks took care the whole process of installing Oracle and HP-UX. We have both Oracle 7 and 8.1.7 running, Oracle 7 is on HP-UX 10.20 and Oracle 8 is on 11.0.
My workstation where the Oracle application client is located is now running HP-UX 11.0, and I have no problem connecting Oracle 8.1.7 using SQLPLUS. But when I try to build my client application which is written using Pro*C, I got such a error. Our application is working fine before we upgrade HP-UX and Oracle.
I am wondering whether this problem is related to HP-UX linker or Oracle library.

Thanks

Rich