Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
cancel
Showing results for 
Search instead for 
Did you mean: 

upgrade mysql on 11.11

someone_4
Honored Contributor

upgrade mysql on 11.11

Hi everyone

I am having an issue upgrading mysql..

Here are the details

Fresh install 11.11 on N classs Risc server

/opt/mysql/bin# ./mysql --version

./mysql Ver 11.15 Distrib 3.23.42, for hp-hpux11.00 (hppa2.0n)

Have version 3.23.42

I have downloaded

ixMySQL_A.02.00-4.0.15_HP-UX_B.11.11_32+64.depot


But when I try to upgrade it gives me the error that mysql is already installed but I want to upgrade to 4.0.15.

This is the depot i downloaded from software.hp.com. I was also thinking of using the depot from http://hpux.cs.utah.edu
but the hp depot should work.

Should I force it reinstall? Or is there another work around that I am missing.

Thanks
Richard

Error:

##########################################

swjob -a log tank-0010 @ tank:/

======= 03/31/04 10:51:36 CST BEGIN install AGENT SESSION (pid=4975)

(jobid=tank-0010)



* Agent session started for user "root@tank". (pid=4975)



* Beginning Analysis Phase.

* Source:

tank:/tmp/ixMySQL_A.02.00-4.0.15_HP-UX_B.11.11_32+64.depot

* Target: tank:/

* Target logfile: tank:/var/adm/sw/swagent.log

* Reading source for product information.

* Reading source for file information.

ERROR: There is another MySQL depot already installed.

Installation cannot proceed.

ERROR: The "checkinstall" script for "xMySQL" failed (exit code "1").

The script location was

"/var/tmp/BAAa04975/catalog/xMySQL/pfiles/checkinstall".

* This script had errors and the execution of this product

cannot proceed until the problem is fixed. Check the above

output from the script for further details.

* Executing preDSA command.

NOTE: The bundle "ixMySQL,r=A.02.00-4.0.15" is already installed.

If you wish to reinstall this bundle, change the "reinstall"

option to "true".

NOTE: All filesets in the product "xMySQL,r=A.02.00-4.0.15" will be

excluded because there was an error in this product.



* Summary of Analysis Phase:

ERROR: Exclude xMySQL.HPUXIXWEBMIN,r=A.02.00-4.0.15

ERROR: Exclude xMySQL.MYSQL-CONF,r=A.02.00-4.0.15

ERROR: Exclude xMySQL.MYSQL-DOC,r=A.02.00-4.0.15

ERROR: Exclude xMySQL.MYSQL-INC,r=A.02.00-4.0.15

ERROR: Exclude xMySQL.MYSQL-LIB,r=A.02.00-4.0.15

ERROR: Exclude xMySQL.MYSQL-MAN,r=A.02.00-4.0.15

ERROR: Exclude xMySQL.MYSQL-RUN,r=A.02.00-4.0.15

ERROR: Exclude xMySQL.MYSQL-SRC,r=A.02.00-4.0.15

ERROR: Exclude xMySQL.MYSQL-TEST,r=A.02.00-4.0.15

ERROR: 9 of 9 filesets had Errors.

ERROR: The Analysis Phase had errors. See the above output for

details.





======= 03/31/04 10:51:40 CST END install AGENT SESSION (Cancelled)

(pid=4975) (jobid=tank-0010)