Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

/usr/lib/dld.sl: Unresolved symbol: naerenc (plabel)

minisoftag
Occasional Visitor

/usr/lib/dld.sl: Unresolved symbol: naerenc (plabel)

 
4 REPLIES
Robert-Jan Goossens
Honored Contributor

Re: /usr/lib/dld.sl: Unresolved symbol: naerenc (plabel)

Hi,

could you check your server for the latest ld and linker tools patch.

Patch Name: PHSS_28434

Patch Description: s700_800 11.00 ld(1) and linker tools cumulative patch

Creation Date: 03/04/16

http://www4.itrc.hp.com/service/cki/patchDocDisplay.do?patchId=PHSS_28434

Regards,

Robert-Jan.
Massimo Bianchi
Honored Contributor

Re: /usr/lib/dld.sl: Unresolved symbol: naerenc (plabel)

and a good recompile of the client !

Massimo
RolandH
Honored Contributor

Re: /usr/lib/dld.sl: Unresolved symbol: naerenc (plabel)

After you have installed OS patches, sometimes you must relink the oracle database like described in that thread
--> http://forums.itrc.hp.com/cm/QuestionAnswer/1,,0x2f963f9a15add711abdc0090277a778c,00.html

If you install the newest ld patch, which is mentioned above, I advice you - relink the database.

HTH
Roland
Sometimes you lose and sometimes the others win
Steven E. Protter
Exalted Contributor

Re: /usr/lib/dld.sl: Unresolved symbol: naerenc (plabel)

The two prior posts I read are excellent and are probably better prospects than my contribution.

But:

I have Internet access.

For the first time in a week.

Seriously, I've solved these type of problems before as follows:

1) make sure the SHLIB_PATH is valid in the user that owns and starts the database.

2) relink the database(not always necessary).

Thats it. Those two steps have been the fix for me. I always believe you should be current with linker/ld patches.

Most of these troubles for me have been rooted in the .profile and user profile of the owner of the database or application(9ias).

Take a look at these areas and your problem will probably be solved.

There have been rare instances where the install/owner user was so messed up I had to reinstall the database software entirely.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com