General
cancel
Showing results for 
Search instead for 
Did you mean: 

/usr/lib/hpux32/dld.so: Unsatisfied code symbol 'PAM_HANDLE_ERROR' in load module '/usr/bin/sudo'.

SOLVED
Go to solution
Kasper_USB
Frequent Advisor

/usr/lib/hpux32/dld.so: Unsatisfied code symbol 'PAM_HANDLE_ERROR' in load module '/usr/bin/sudo'.

We have installed sudo from IE-Express.
Now on trying sudo from unprivileged user we got this error.
Any ideas ?

HPUX 11.31
3 REPLIES
smatador
Honored Contributor
Solution

Re: /usr/lib/hpux32/dld.so: Unsatisfied code symbol 'PAM_HANDLE_ERROR' in load module '/usr/bin/sudo'.

Hi,

The 11.23 sudo software work on 11.31.

Normally it's better to install sudo from IE-Express, but you could also install it from http://hpux.connect.org.uk/hppd/hpux/Sysadmin/sudo-1.6.9p19/
http://hpux.connect.org.uk/hppd/hpux/Sysadmin/sudo-1.7.0/
Eric Yruegas
Frequent Advisor

Re: /usr/lib/hpux32/dld.so: Unsatisfied code symbol 'PAM_HANDLE_ERROR' in load module '/usr/bin/sudo'.

Kasper-

I had the exact same error - only popped up on commands set to require password. I ended up going and downloading one of the ones from the HPUX Porting Center as the other poster suggested. Works fine now!
Sergey Akifiev_1
Frequent Advisor

Re: /usr/lib/hpux32/dld.so: Unsatisfied code symbol 'PAM_HANDLE_ERROR' in load module '/usr/bin/sudo'.

hi
i hit this problem too, but on hpux 11.23 ia. but on 11.23 hppa box, which didn't have much software installed, sudo from hp works without a hitch.

my thought is that some third-party software (library most likely) interfere with system one. that 11.23ia box have sudo 1.6.8p9 from hpux.connect.org.uk installed. i'm going to check this out...