General
cancel
Showing results for 
Search instead for 
Did you mean: 

very urgent- e2fsck error...

eugene_6
Advisor

very urgent- e2fsck error...

hello

i'm using mandrake8.1
kde.. on laptop.

i don't know why this error occured. i didn't install anything new.
(i might messed up kernel. i accidently installed kernel package through rpm-installer. and my system didn't boot up.(error message was : ebda too large), by the way i fixed that problem and booted my system up again)

i rebooted my box several times after that. it worked fine. (i didn't install anything after messing up kernel thing)
and suddenly, it doesn't boot up again. giving me message like this..

Checking root filesystem
/dev/hda5 is mounted e2fsck: cannot continue
Failed to check Filesystem.

what's wrong?

i looked at /etc/mtab
there's /dev/hda5( / )
i tried to umount it mannually
but it never got unmounted
that's the problem?


thank you very much...
plz help me..
3 REPLIES
Kodjo Agbenu
Honored Contributor

Re: very urgent- e2fsck error...

Hello Eugene,

Just in case :

1. If you are using the ext2-Labels mechanism (generally implemented in RedHat and Mandrake), try to edit your /etc/fstab to comme back to the "normal" mechanism :



for example, my /etc/fstab looks like this :

/dev/hda5 / ext3 defaults 1 1
/dev/hda1 /nt vfat uid=500 0 0
/dev/hda2 /share vfat uid=500 0 0
/dev/hda6 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom auto noauto,map=off,owner,kudzu,ro 0 0
/dev/floppy /mnt/floppy auto noauto,sync,owner 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
none /dev/pts devpts gid=5,mode=620 0 0



If you cannot boot (so fstab cannot be edited), just try to boot in single user mode (type "linux s" at LILO prompt). If it succeeds, remount the root partition readonly (type "mount -oremount,ro /"), then do e2fsck manually (e2fsck /dev/hda5).

After that, remount the root filesystem in read-write mode (mount -oremount,rw /) then edit the /etc/fstab as mentioned above.

Good luck.

Kodjo
Learn and explain...
eugene_6
Advisor

Re: very urgent- e2fsck error...


thx kodjo..



the rpm-kernel upgrade(of mandrake8.1) added some stuff to lilo.conf file..
since i didn't complete upgrade, the conf file didn't have correct information about my system.
i deleted the added lines.
and it works now...

and another possible solution for this error could be giving read-only option at the "lilo:" prompt
----------------------
lilo: linux read-only
----------------------


Eugene Kim
Jaime Bonilla
Occasional Visitor

Re: very urgent- e2fsck error...

Other good Solution to this problem is use Grubs as boot manager instead of lilo.