General
cancel
Showing results for 
Search instead for 
Did you mean: 

vgchange: not a character device.

SOLVED
Go to solution

vgchange: not a character device.

Hi ,
I've removed everything in the volume group /dev/vgnetapp_omxlab8 (mountponit,logical,filesystem and so on..)
and
rm -r /dev/vgnetapp_omxlab8/group

but when I run command 'vgchange -a -y' ,it still displays "not a character device" . How to remove this warning in the system ?

$vgchange -a y
Volume group "/dev/vgnetapp_tnptplan" has been successfully changed.
vgchange: "/dev/vgnetapp_omxlab8/group": not a character device.

Best regard
Tien
5 REPLIES
rariasn
Honored Contributor

Re: vgchange: not a character device.

Hi:

# vgexport -m /tmp/vgnetapp_omxlab8.amp vgnetapp_omxlab8

Export the volume group /dev/vgnetapp_omxlab8 into mapfile. The volume group will be removed from the exporting system

# vgchange -a y

rgs,

Re: vgchange: not a character device.

Hi

vgexport -m /tmp/vgnetapp_omxlab8.amp vgnetapp_omxlab8
Error I've got:
vgexport: "/dev/vgnetapp_omxlab8/group": not a character device.
vgexport: Couldn't export volume group "vgnetapp_omxlab8".

regard
Tien
rariasn
Honored Contributor
Solution

Re: vgchange: not a character device.

Hi:

# mknod /dev/vgnetapp_omxlab8/group c 64 0xNN0000

The minor number for the group file should be unique among all the volume groups on the system. It has the format 0xNN0000, where NN runs from 00 to ff. The maximum value of NN is controlled by the kernel tunable parameter maxvgs.


# vgexport -m ....


rgs,

Re: vgchange: not a character device.

Hi rariasn

Now it works perfectly as you showed me .
Thank you very much .

Best regard.
Tien

Re: vgchange: not a character device.

I have found a solution to this question as seen in the comments below.