Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

vim & active backspace key

SOLVED
Go to solution
tony j. podrasky
Valued Contributor

vim & active backspace key

O/S: RedHat 3.0 AS

The BACKSPACE key works fine under
all other applications.

When I use the backspace key is
always active: if I position the cursor on a line, and press the backspace key, it begins deleting text. Not only that, but it deletes text to the right of it, not to the left.

How can I make it inactive during visual mode,
and delete text to the left during insertion mode?

regards,
tonyp
REMEMBER: Once you eliminate your #1 problem, #2 gets a promotion.
4 REPLIES
Stuart Browne
Honored Contributor

Re: vim & active backspace key

Within 'vim', if you type 'set', what its the setting 'backspace' set too?

As 'backspace=2' on my system, it will move the cursor in non-edit mode, and delete-char-to-left in insert mode.
One long-haired git at your service...
tony j. podrasky
Valued Contributor

Re: vim & active backspace key

Hey Stuart;

It is set to backspace=2.

I found that the problem was with the
terminal environment: somehow instead of ^?.

When I changed that, all was well.

It sure is great having several LINUX boxes handy with difference revs of the O/S.

I just U/G'd to RH 3.0 AS from RH 6.1 - only because the ancient Netscape browser was choking on .asp pages.

regards,
tonyp
REMEMBER: Once you eliminate your #1 problem, #2 gets a promotion.
Steven E. Protter
Exalted Contributor
Solution

Re: vim & active backspace key

Check stty -a

Check your backspace settings in /etc/profile and or .bash_profile

See if the results are consistent with other telnet/ssh clients, remote and local.

I am using the same release of Red Hat to type this post and DO NOT have the same results.

Maybe I accidentally got something right.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
tony j. podrasky
Valued Contributor

Re: vim & active backspace key

Hi Steve;

Yes - that's where I found the difference.

I don't know what caused it to be messed up. It could be an anomoly that happened when I switched from BASH to TCSH.

Thanx for the input.

regards,
tonyp
REMEMBER: Once you eliminate your #1 problem, #2 gets a promotion.