cancel
Showing results for 
Search instead for 
Did you mean: 

w3m installation

Rizwan84tx
Frequent Advisor

w3m installation

Hi Techys,

My w3m installation failed. I get an error

# make
awk '/^#ifdef makefile_parameter/,/^#else/' config.h | cat - XMakefile >
make -f XXMakefile
cc -O -I./gc -I/usr//include -I/usr//include/openssl -I. -c keybind.c
rv libaa.a Str.o indep.o regex.o textlist.o parsetag.o
Make: Cannot load rv. Stop.
*** Error exit code 1

Stop.
*** Error exit code 1

==============================================
I have attached the complete installation log, help me !!!
25 REPLIES
Dennis Handly
Acclaimed Contributor

Re: w3m installation

>rv libaa.a Str.o indep.o regex.o textlist.o parsetag.o
>Make: Cannot load rv. Stop.

It looks like you haven't defined $(AR).
Shinji Teragaito_1
Respected Contributor

Re: w3m installation

What is the script you're using prior to 'make' ?

Why don't you use the configure script included in the w3m tar
package ?

I've been using w3m for a long time on HP-UX. It works 11.11,
11.23 and 11.31. I've never seen such an error after invoking
make.

As Dennis mentioned, $(AR) is not defined in your Makefile.

As of today, 0.5.2 is available. I tried to build it on 11.31. No
problems. It works as I expected.
Rizwan84tx
Frequent Advisor

Re: w3m installation

I tried "configure.sh" prior to "make". I don't understand, y I'm getting this error. Any clue?
Shinji Teragaito_1
Respected Contributor

Re: w3m installation

Did you define $(AR) in your Makefile ? If not, you should do it.

By the way, did you download w3m source code from sourceforge ?

http://sourceforge.net/projects/w3m/

NOTE: I can not find configure.sh in both w3m-0.5.1 and 0.5.2
source code files.
Rizwan84tx
Frequent Advisor

Re: w3m installation

I downloaded w3m 0.2.1 from hpux.connect.org. I will try what you suggested. What is AR variable, i have no clue in defining that..
Shinji Teragaito_1
Respected Contributor

Re: w3m installation

configure script defines it.
Rizwan84tx
Frequent Advisor

Re: w3m installation

I did try to install from the download link u gave,but ended up in an error.I have attached the whole log for you, that can help.
Shinji Teragaito_1
Respected Contributor

Re: w3m installation

you should read doc/README.
Rizwan84tx
Frequent Advisor

Re: w3m installation

I did the following

1.Downloaded gc-7.0
->ran configure script
->make
->make install

2.Then i came to w3m.
->ran configure and suceeded without errors.
->ran make

while running make script i get this error.
---------------------------------------------
ld: Can't find library or mismatched ABI for -lwc
Fatal error.
*** Error exit code 1
---------------------------------------------

I have attached the whole log too.

Did i do any mistake?

Dennis Handly
Acclaimed Contributor

Re: w3m installation

>ld: Can't find library or mismatched ABI for -lwc
>I have attached the whole log too.

Do you know where your libwc.* is?
Is it in your libwc/ directory?
Shinji Teragaito_1
Respected Contributor

Re: w3m installation

Didn't your Makefile generate libwc/libwc.a ?

..(snip)..
cc -I.. -I.. -I. +O2 -I/opt/openssl/include/ -I./libwc -I/opt/openssl/include/
openssl -I/opt/openssl/include -I/usr/local/include -I/usr/local/include -DUSE_
UNICODE -I. -I./.. -DHAVE_CONFIG_H -c -o wtf.o wtf.c
ar rv libwc.a big5.o ces.o char_conv.o charset.o combining.o conv.o detect.o gb1
8030.o gbk.o hkscs.o hz.o iso2022.o jis.o johab.o priv.o putc.o search.o sjis.o
status.o ucs.o uhc.o utf7.o utf8.o viet.o wtf.o
ar: creating libwc.a
..(snip)..
Rizwan84tx
Frequent Advisor

Re: w3m installation

Thank you for your replies, while running configure in w3m; i get the below warnings. Will these impact this problem

checking image library... gtk2 gdk-pixbuf imlib imlib2
configure: WARNING: GdkPixbuf is not installed. Install GdkPixbuf (version >= 2.0.0)
configure: WARNING: GdkPixbuf is not installed. Install GdkPixbuf (version >= 0.16.0)
configure: WARNING: Imlib is not installed. Install Imlib (version >= 1.9.8)
configure: WARNING: Imlib2 is not installed. Install Imlib2 (version >= 1.0.5)
configure: WARNING: unable to build w3mimgdisplay with X11 support


And i have no idea where libwc is located, i don't have any clue!
Shinji Teragaito_1
Respected Contributor

Re: w3m installation

I have the same warning messages when invoking the configure
script. But I don't care them because I don't need to display
graphics using w3m :-) If you want to have such needs, I'd
recommend you to install the related graphics libraries with the
header files.

You should have libwc/libwc.a in the w3m source directory. As I
mentioned, libwc.a is created during executing w3m make.

Do your Makefile have "WCTARGET = libwc/libwc.a" ?
Rizwan84tx
Frequent Advisor

Re: w3m installation

I observed that w3m has libwc directory, but libwc.a is not inside the libwc.

I checked the Makefile in w3m, it has "WCTARGET = libwc/libwc.a".
Shinji Teragaito_1
Respected Contributor

Re: w3m installation

Unless you use m17n, please specify --disable-m17n to the configure script.
(refer to doc/README.m17n)

Then you should have w3m which don't need libwc/libwc.a.
Rizwan84tx
Frequent Advisor

Re: w3m installation

I'm really confused, i don't understand a thing in that README.m17n. Do i need to modify the configure script? how to specify --disable-m17n to the configure script? Could you guide me.
Shinji Teragaito_1
Respected Contributor

Re: w3m installation

For example,

% ./configure --disable-m17n

I don't know exactly where gc is installed on your environment.
Fortunately, configure may find its headers and
libraries. Otherwise you have to give the appropriate information
to configure script.

By the way, here's a tips to avoid a termcap error.

% diff terms.c.orig terms.c
714a715,717
> #ifdef __hpux
> if (r == -1) {
> #else
715a719
> #endif
%

I'd recommend you to modify terms.c described above unless you
are using ncurses.
Rizwan84tx
Frequent Advisor

Re: w3m installation

It says configure --disable-m17n could not be found.
Rizwan84tx
Frequent Advisor

Re: w3m installation

Hi I executed disable --m17n and i got 29 error "unsatisfied symbol"

-----------------------------------------------
# make
cc -I. -I. -g -I/usr/include/openssl -I/usr/local/include/gc -I/usr/local/include/gc -DHAVE_CONFIG_H -DAUXBIN_DIR=\"/usr/local/libexec/w3m\" -DCGIBIN_DIR=\"/usr/local/libexec/w3m/cgi-bin\" -DHELP_DIR=\"/usr/local/share/w3m\" -DETC_DIR=\"/usr/local/etc\" -DCONF_DIR=\"/usr/local/etc/w3m\" -DRC_DIR=\"~/.w3m\" -DLOCALEDIR=\"/usr/local/share/locale\" -c version.c
cc -I. -I. -g -I/usr/include/openssl -I/usr/local/include/gc -I/usr/local/include/gc -DHAVE_CONFIG_H -DAUXBIN_DIR=\"/usr/local/libexec/w3m\" -DCGIBIN_DIR=\"/usr/local/libexec/w3m/cgi-bin\" -DHELP_DIR=\"/usr/local/share/w3m\" -DETC_DIR=\"/usr/local/etc\" -DCONF_DIR=\"/usr/local/etc/w3m\" -DRC_DIR=\"~/.w3m\" -DLOCALEDIR=\"/usr/local/share/locale\" -o w3m main.o file.o buffer.o display.o etc.o search.o linein.o table.o local.o form.o map.o frame.o rc.o menu.o mailcap.o image.o symbol.o entity.o terms.o url.o ftp.o mimehead.o regex.o news.o func.o cookie.o history.o backend.o keybind.o anchor.o parsetagx.o tagtable.o istream.o version.o -L/usr/local/lib -lm -L. -lindep -L/usr/local/lib -lgc -lssl -lcrypto -lcurses
ld: Unsatisfied symbol "wc_putc_clear_status" in file terms.o
ld: Unsatisfied symbol "WTF_TYPE_MAP" in file file.o
ld: Unsatisfied symbol "wc_Str_conv" in file main.o
ld: Unsatisfied symbol "wc_guess_8bit_charset" in file linein.o
ld: Unsatisfied symbol "wtf_is_hangul" in file file.o
ld: Unsatisfied symbol "wtf_len" in file display.o
ld: Unsatisfied symbol "wc_putc_init" in file terms.o
ld: Unsatisfied symbol "WTF_LEN_MAP" in file file.o
ld: Unsatisfied symbol "wc_char_conv" in file linein.o
ld: Unsatisfied symbol "wc_ucs_to_utf8" in file entity.o
ld: Unsatisfied symbol "wc_guess_locale_charset" in file main.o
ld: Unsatisfied symbol "wtf_init" in file main.o
ld: Unsatisfied symbol "wc_guess_charset_short" in file main.o
ld: Unsatisfied symbol "wc_char_conv_init" in file linein.o
ld: Unsatisfied symbol "wtf_push" in file symbol.o
ld: Unsatisfied symbol "wc_putc" in file terms.o
ld: Unsatisfied symbol "WTF_WIDTH_MAP" in file file.o
ld: Unsatisfied symbol "wtf_conv_fit" in file search.o
ld: Unsatisfied symbol "wc_Str_conv_strict" in file main.o
ld: Unsatisfied symbol "wc_Str_conv_with_detect" in file file.o
ld: Unsatisfied symbol "wc_putc_end" in file terms.o
ld: Unsatisfied symbol "wc_get_ces_list" in file map.o
ld: Unsatisfied symbol "wtf_strwidth" in file file.o
ld: Unsatisfied symbol "wtf_get_code" in file file.o
ld: Unsatisfied symbol "wtf_parse1" in file regex.o
ld: Unsatisfied symbol "wc_ces_to_charset_desc" in file main.o
ld: Unsatisfied symbol "WcOption" in file main.o
ld: Unsatisfied symbol "wc_ces_to_charset" in file main.o
ld: Unsatisfied symbol "wc_guess_charset" in file file.o
29 errors.
*** Error exit code 1

Stop.
Shinji Teragaito_1
Respected Contributor

Re: w3m installation

% cd ~/oss/w3m-0.5.1
% ./configure --help | grep m17n
--disable-m17n do not use m17n
%
% cd ~/oss/w3m-0.5.2
% ./configure --help | grep m17n
--disable-m17n do not use m17n
%

I believe you can download w3m-0.5.2. So you can specify
--disable-m17n. I don't understand why you didn't specify it.
This option doesn't define USE_M17N flag in config.h. Then it
can avoid your unsat errors.

Good luck !!
Rizwan84tx
Frequent Advisor

Re: w3m installation

Hi I did specify

%./configure --disable-m17n

Even then i'm getting the Unsat errors. I downloaded w3m-0.5.2 again and tried, still the no luck :(
Shinji Teragaito_1
Respected Contributor

Re: w3m installation

Suppose you have w3m-0.5.2 source files.

1. % make clean
2. Change config.h as follows:

% vi config.h

#define HELP_FILE "w3mhelp-w3m_en.html"

#define DISPLAY_CHARSET WC_CES_US_ASCII
#define SYSTEM_CHARSET WC_CES_US_ASCII
#define DOCUMENT_CHARSET WC_CES_US_ASCII
/* #undef USE_M17N */
/* #undef USE_UNICODE */
#define W3M_LANG EN

3. % make
Rizwan84tx
Frequent Advisor

Re: w3m installation

Hi,

I appreciate your help alot. I did "make clean" the "config.h" had same values as u suggested.Then i ran "make", but this time i was stopped with a new error.

gcc -I. -I. -g -O2 -I/usr/include/openssl -I/usr/local/include/gc -I/usr/local/include/gc -DHAVE_CONFIG_H -DAUXBIN_DIR=\"/usr/local/libexec/w3m\" -DCGIBIN_DIR=\"/usr/local/libexec/w3m/cgi-bin\" -DHELP_DIR=\"/usr/local/share/w3m\" -DETC_DIR=\"/usr/local/etc\" -DCONF_DIR=\"/usr/local/etc/w3m\" -DRC_DIR=\"~/.w3m\" -DLOCALEDIR=\"/usr/local/share/locale\" -o w3mimgdisplay w3mimgdisplay.o w3mimg/w3mimg.a -L/usr/local/lib -lm
gcc: w3mimg/w3mimg.a: No such file or directory
*** Error exit code 1


I looked in w3m directory there is no w3mimg/w3mimg.a.

# cd w3mimg
# ls
.cvsignore Makefile Makefile.in fb w3mimg.c w3mimg.h x11
#
# ls -la
total 24
drwxr-xr-x 4 1000 root 1024 Sep 25 08:54 .
drwxr-xr-x 11 1000 root 4096 Sep 26 02:08 ..
-rw-r--r-- 1 1000 root 9 Sep 22 2003 .cvsignore
-rw-r--r-- 1 root sys 713 Sep 25 08:54 Makefile
-rw-r--r-- 1 1000 root 722 Apr 26 2004 Makefile.in
drwxr-xr-x 2 1000 root 1024 Sep 25 08:54 fb
-rw-r--r-- 1 1000 root 708 Nov 5 2002 w3mimg.c
-rw-r--r-- 1 1000 root 1416 Jul 13 2003 w3mimg.h
drwxr-xr-x 2 1000 root 96 Sep 25 08:54 x11
Dennis Handly
Acclaimed Contributor

Re: w3m installation

>I looked in w3m directory there is no w3mimg/w3mimg.a.

So go there and make it?