General
cancel
Showing results for 
Search instead for 
Did you mean: 

weird Fiber Channel device issue

C'est Pierre
Advisor

weird Fiber Channel device issue

Hello,

I've got 2 FC interfaces connected an EVA 3000 storage and somehow, since I installed qla2xx src, the /dev/sdb disappeared and only /dev/sda appears now!

Any hints?

Thank you
6 REPLIES
Uwe Zessin
Honored Contributor

Re: weird Fiber Channel device issue

Unless you have presented 2 virtual disks to the server, it sounds like the driver now operates in multipath mode and filters redundant paths.
.
C'est Pierre
Advisor

Re: weird Fiber Channel device issue

How can I be sure of that? since I haven't made any multipathing yet, it's tricky how the 2nd device disappeared, but I could accept that as answer, but before I do finally accept it, I would like to be sure of that :)

Thanks
Colin Topliss
Esteemed Contributor

Re: weird Fiber Channel device issue

So you compiled and installed new QLA drivers, right?

Have you checked that both your adapters are back on-line?

Do:

cat /proc/scsi/qla2xxx/0
cat /proc/scsi/qla2xxx/1

and check that they are both ready....

Host adapter:loop state = , flags = 0xa03

If not, then you've lost a fibre connection....

I'd have to check how the QLA failover works. I'd have thought it would use a different driver (much like multipathd does - it uses /dev/dm-xxx).
C'est Pierre
Advisor

Re: weird Fiber Channel device issue

# grep -i ready /proc/scsi/qla2xxx/*
/proc/scsi/qla2xxx/0:Host adapter:loop state = , flags = 0x1a03
/proc/scsi/qla2xxx/1:Host adapter:loop state = , flags = 0x1a03

Apparently, it's ready. I don't know what it is about, but this only happens as soon as I install the HBA drivers: hp_qla2x00src-8.01.03-14.

# lspci|grep Fibre
0000:06:01.0 Fibre Channel: QLogic Corp. QLA2312 Fibre Channel Adapter (rev 02)
0000:06:01.1 Fibre Channel: QLogic Corp. QLA2312 Fibre Channel Adapter (rev 02)
Barry Lowe
Advisor

Re: weird Fiber Channel device issue

Try this:

cat /proc/scsi/qla2xxx/* | grep version

if the line ends with fo then you have failover configured.

This is usually activated by having something like this in modprobe.conf:

options qla2xxx ql2xfailover=1

This may have been activated by default after you installed the new driver. Conversely you could explicitly set the above parameter to 0 to de-activate the failover.
C'est Pierre
Advisor

Re: weird Fiber Channel device issue

Thank you, issue solved.