cancel
Showing results for 
Search instead for 
Did you mean: 

wlm and JRE

A.G.M. Velthof
Valued Contributor

wlm and JRE

hello to all,

I want to start wlmgui and I get the message Java Runtime Environment not found.

In /opt I see java6, java7 and java8 installed.

What need I to do more?

2 REPLIES
A.G.M. Velthof
Valued Contributor

Re: wlm and JRE

no one has any idea? I checked on other HPUX systems and wlmgui runs on them.

I don't see any difference in the profile or other settings.

ranganath ramachandra
Esteemed Contributor

Re: wlm and JRE

 

[ ranga ] $ whereis wlmgui
wlmgui: /opt/wlm/bin/wlmgui /opt/wlm/share/man/man1m.Z/wlmgui.1m
[ ranga ] $ file /opt/wlm/bin/wlmgui
/opt/wlm/bin/wlmgui:    commands text
[ ranga ] $ egrep -i 'java|jre' /opt/wlm/bin/wlmgui
set -A jre_list \
        /opt/java1.5/jre/bin/java \
        /opt/java1.5/bin/java
# Locate an installed Java Runtime Environment
for jre in "${jre_list[@]}"
    if [[ -x "${jre}" ]]
        java="${jre}"
# Abort if a JRE was not found.
if [[ -z "${java}" ]]
    print -u2 "$prog: Java Runtime Environment not found."
    print -u2 "*** Check that JRE is installed!"
cp=${cp}:/opt/wlm/lib/mongui/jh.jar             # JavaHelp class
opts="-Xms128m -Xmx128m -Djava.net.preferIPv4Stack=false -classpath ${cp}"
# Run java.  Direct the error stream to a file.
${java} ${opts} com.hp.wrm.monitor.WLMGUI 2>${output_file}
[ ranga ] $ /usr/sbin/swlist -l file | grep /opt/wlm/bin/wlmgui
  WLM-Monitor.WLMGUI-RUN: /opt/wlm/bin/wlmgui

Looks like your version of java is too new for this (?) version of WLM-Monitor.

If you don't want to do this:

ln -fs /opt/java8 /opt/java1.5

you could edit the shell script to update "jre_list".