Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

ximian does'nt popup via xdmcp

SOLVED
Go to solution
Donny Jekels
Respected Contributor

ximian does'nt popup via xdmcp

Installed

B6852BA+B6848BA-r2-PA_11.X.depot

and gnome does not start with xmdcp, I did enable xdmcp.
"Vision, is the art of seeing the invisible"
7 REPLIES
John Meissner
Esteemed Contributor
Solution

Re: ximian does'nt popup via xdmcp

after you installed gnome dod you edit
/etc/rc.config.d/desktop
and change the line:
DESKTOP=CDE
to
DESKTOP=GNOME
?
or you can use the following command
/usr/sbin/ch_rc -ap DESKTOP=GNOME /etc/rc.config.d/desktop

once either is done issue the following command
/sbin/init.d/gdm.rc start

if you get a message stating that gdm is already running use the following commands:
/sbin/init.d/gdm.rc stop
/sbin/init.d/gdm.rc start


All paths lead to destiny
Alex Glennie
Honored Contributor

Re: ximian does'nt popup via xdmcp

As I understand things gnome will look in /etc/opt/gnome/gdm/gdm.conf for :

[xdmcp]
Enable=true

which by default is disabled, if you edit this file you would need to restart the
/opt/gnome/bin/gdm -daemon

Is this the case ? Saying that gnome is a bit flakey but I've not experienced it failing to work once the above was set.

John Meissner
Esteemed Contributor

Re: ximian does'nt popup via xdmcp

oops... i just detailed how to install gnome on a desktop..... he he.... my mistake

All paths lead to destiny
John Meissner
Esteemed Contributor

Re: ximian does'nt popup via xdmcp

if using exceed to connect (is this how you are connecting?)

you will need to stop the CDE login manager by typing
/sbin/init.d/dtlogin.rc stop

All paths lead to destiny
Donny Jekels
Respected Contributor

Re: ximian does'nt popup via xdmcp

I have done everything you guys had replied before I posted my question.

i am going to try it agian tomorrow, will keep you posted.
"Vision, is the art of seeing the invisible"
Rick Beldin
Esteemed Contributor

Re: ximian does'nt popup via xdmcp

Don't forget to enable xdmcp support for gdm. By default it is turned off.

Look in /etc/opt/gnome/gdm/gdm.conf.

Change this line:

[xdmcp]
Enable=false

to

[xdmcp]
Enable=true
Necessary questions: Why? What? How? When?
Mike Stroyan
Honored Contributor

Re: ximian does'nt popup via xdmcp

You do need to stop and restart gdm in order to get it to reread gdm.conf. The running gdm can be stubborn about not stopping, so check with ps to be sure it stopped.