cancel
Showing results for 
Search instead for 
Did you mean: 

zt1145 doesn't boot Linux

Pat Rondon
Occasional Contributor

zt1145 doesn't boot Linux

Hi... I installed Gentoo Linux on a zt1145, set GRUB to take over the MBR, and was treated to this lovely error message:
"Hard disk boot sector invalid"
Installing a copy of Windows XP works as expected, so there must be some bias against Linux MBRs, as LILO won't work either. Any help would be greatly appreciated.
3 REPLIES
Jinsong Liang
Occasional Visitor

Re: zt1145 doesn't boot Linux

I had the same problem with ze1202. After numerous experiments, my conclusion is that HP hates Linux. Following are the evidence:

1. If lilo is installed in MBR to erase HP's MBR, you can boot into Linux without problem, but you can not boot into winxp.

2. If lilo is installed in boot partition leaving HP's MBR untouched, you can boot into winxp, but you can not boot into Linux.

3. The HP's MBR is not compatible with traditional MBR written by "fdisk /mbr". After "fdisk /mbr", you can not even install windows2000.

I just returned ze1202. I think if you need Linux ,forget about HP.
Ted M Johnson_1
Frequent Advisor

Re: zt1145 doesn't boot Linux

Do you want a single boot Linux box, or a dual boot Lin/Win box?

If you only want Linux, I'd suggest you clean the entire HDD, including any hidden partitions.

Use "fdisk /dev/hda" to delete all the partitions, and make a new set. I'd suggest this:

/dev/hda1 swap
/dev/hda2 /boot
/dev/hda3 /
/dev/hda4 (data partition)

This will remove any "extra" partition you might have on the laptop which may be causing the problem.

If you want a dual boot system, why not let Windows boot the system, and install lilo to the first sector of boot instead of the MBR? Since Windows will boot, this option should work fine.


YMMV
James Wilson_5
Frequent Advisor

Re: zt1145 doesn't boot Linux

I have successfully installed Getoo on my zt1145. Grub works without a problem.

I have a huge amount of partitions (Don't ask:), but the basics should be the same.

bash-2.05a# grub
grub> root (hd0,4) (Note (hd0,4) is the partition my /boot is mounted on)
grub> setup (hd0) (Install on MBR)
grub> quit


I also created a menu.lst in /boot/grub:

default 5
timeout 30
colour light-gray/blue black/light-gray
splashimage=(hd0,4)/grub/splash.xpm.gz # default image

title=James' Gentoo Linux
root (hd0,4)
kernel /bzImage-2.5.31 root=/dev/hda7 hdc=ide-scsi

title=Windows XP
rootnoverify (hd0,1)
makeactive
chainloader +1


Hope this helps