Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
HP 9000 and HP e3000 Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

Question about Quad card on A500

dictum9
Super Advisor

Question about Quad card on A500


I am having issues with an A500 running 11.23.

It has dual quad cards installed and course Core IO.

None of the links work, it's like the drops went dead, core IO included.

When looking at the Quad card, how do you know which one is lan1 and which one is lan4?

I tried lanscan with netstat but cannot arrive to a conclusion.

2 REPLIES
Bill Hassell
Honored Contributor

Re: Question about Quad card on A500

Unfortunately, there are no labels on the cards that translate to an actual lan PPA number (lan2 lan3, etc). So I let lanadmin identify the cards for me. Run this command to find all the LAN ports:

ioscan -kfC lan

The I (card Instance number 0 1 2 3 4) is also known as the PPA number or the number at the end of the lan# designation.

Now, unplug all LAN cables in the 4channel card. Then plug one cable into the first port on the card (you decide which way to count). Plug the other end of the cable into a switch. Then, assuming lan1 through lan4 are the ports on the LAN card, run these two commands:

lanadmin -g 1 | grep Operation
lanadmin -g 4 | grep Operation

One of them will report: Up
That is the lan number for that port.

As far as all the ports going dead, run lanadmin -g on every port like this:

for PPA in 0 1 2 3 4
do
echo "lan$PPA \c"
lanadmin -g $PPA | grep Operation
done

If they are all down, then your switch must be powered off or disabled.


Bill Hassell, sysadmin
Andrew Rutter
Honored Contributor

Re: Question about Quad card on A500

hi,

if all links have gone down it cannot be anything wrong with server hardware, or very unlikley

sounds like the switch has gone down or someone has changed the config possibly at the switch end to something 1000bt fixed and not compatible with the cards and speed there capable of.

presumably networking hasnt been changed on server? do they still all have the correct ip's/subnet?

you could try and do a linkloop to the mac address of the cards if you have another machine

Andy