HP-UX

낮은 버전 설치시 어케 해야 되나요?

 
신동국
비정기 기여자

낮은 버전 설치시 어케 해야 되나요?

안녕하세요



현재 java 1.4랑 1.5랑 설치 되어 있는대요

1.4버젼을 설치 할려구 합니다. 기존보다 낮아서 설치시 에러가 나는데 알려주세요....



ERROR: A later revision (one with a higher revision number) of fileset "Jdk14.JDK14-DEMO,r=1.4.2.08.02" has already been installed.Either remove this fileset or change the "allow_downdate"option to "true"
3 응답 3
김병수
본과생

낮은 버전 설치시 어케 해야 되나요?

그럼 1.5 자바를 지우시면 되지 않나요..



아니면 구지 1.5를 지우시 마시구 path를 1.4에 있는 java를 먼저 불러 오게 하면 됩니다.



# whence java



에서 확인..



그럼~~
김진호_4
비정기 기여자

낮은 버전 설치시 어케 해야 되나요?

설치할려는 java1.4버전(1.4.2.08.02)이 현재 설치되어 있는 java1.4버전보다 낮아서 그런거 같네요.

www.hp.com/go/java로 들어가셔서 1.4상위버전을 받아서 설치하던지 아니면 설치되어 있는 java1.4를 제거하시고 다시 설치하시면 됩니다.
정우익
임시 조언자

낮은 버전 설치시 어케 해야 되나요?

java를 여러번 설치를 해봤는데요..



일단 /opt 아래에 있는 java의 path를 변경 해주세요



아마도 /opt/java1.4 혹은 /opt/java1.5 라고 되어 있을 것입니다.



현재 있는 java 를 그대로 두고 재설치 하시려면 java1.4 를 java1.4.08 로 변경하시고 java를 재설치 하시면 원하시는 version이 설치가 되실 겁니다.



아니면 swremove 로 java1.4를 삭제 하시고 다시 설치하시는 방법도 있구요



java1.5가 설치 되어 있다고 하더라도 java1.4는 설치 됩니다.