HP-UX

두번째 질문 swinstall 시 장애로그입니다. 확인부탁드려요

 
Woo Sangdon
임시 조언자

두번째 질문 swinstall 시 장애로그입니다. 확인부탁드려요

/tmp/qt/gdb-5.3-sd-11.00.depot를 설치할려고 하니 아래의 에러가 뜨네요 다시금 어떻게 해야하는지... 알려주세요.



#swlist 하면

gdb 4.18 gdb

버전이 깔려 있습니다. 그래서 그런가요?

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~



======= 05/03/04 10:46:26 KST BEGIN install AGENT SESSION (pid=10302)

(jobid=pshell-0122)



* Agent session started for user "root@pshell.postech.ac.kr".

(pid=10302)



* Beginning Analysis Phase.

* Source:

pshell.postech.ac.kr:/tmp/qt/gdb-5.3-sd-11.00.depot

* Target: pshell:/

* Target logfile: pshell:/var/adm/sw/swagent.log

* Reading source for product information.

* A version of the fileset exists:

"gdb.gdb-RUN,l=/opt/gdb,r=4.18".

This fileset version is already configured.

ERROR: A version of fileset "gdb.gdb-RUN,r=5.3" is already installed

in another location (see previous lines). Installing this

version will create multiple installed versions.

You must either remove that fileset or change the

"allow_multiple_versions" option to "true".

WARNING: No filesets in the product "gdb,r=5.3" will be configured as

part of the install, because there is another version with a

same fileset already configured. If you want multiple

configured versions you must run "swconfig" with the

"allow_multiple_versions" option set to "true".

* Reading source for file information. v * Executing preDSA command.



* Summary of Analysis Phase:

ERROR: Exclude gdb.gdb-RUN,r=5.3

ERROR: 1 of 1 filesets had Errors.

ERROR: The Analysis Phase had errors and warnings. See the above

output for details.
2 응답 2
이태곤
중학생

두번째 질문 swinstall 시 장애로그입니다. 확인부탁드려요

fileset이 이미설치되어 있어서 설치가 안되는것 같습니다.

기존에 설치되어 있는 것을 삭제하시거나 multiple version 옵션을 주셔서 설치하시면 됩니다.





# swinstall -x allow_multiple_versions=true -s /tmp/qt/gdb-5.3-sd-11.00.depot
이명우
정기 조언자

두번째 질문 swinstall 시 장애로그입니다. 확인부탁드려요

해결방법은 로그 내용 그대로 인것 같습니다.

swremove 로 선택하여 기존 Verison을 삭제하시고 설치하시거나

swinstall 메뉴 화면이 나오면 화면 상단에 Options 메뉴가

있습니다.

그곳에서 Allow creation of multiple versions 에

Check를 해주시고 설치하시면 됩니다.



어떤것이 더 좋을지는 판단하시겠지만 가능한한 여러 Version이

동일 Host에 있게 되면 나중에 관리하시는데 문제가 생길 가능성이

있습니다.



그럼 잘 해결되시길 빌겠습니다.