HP-UX

GCC 두가지 version 관련

 
장준학
비정기 기여자

GCC 두가지 version 관련

GCC 4.1.0 및 3.4.2에 관련된 질문입니다.



1. 3.4.2에서 C++ 및 STL을 이용하여 작성된 library들을 4.1.0에서 그대로 사용할 수 있는지요? Major version이 달라 의문이 됩니다.



2. 사용하는데 문제가 있을 수 있다면 기존 GCC 4.1.0이 설치되어 있는 시스템에 3.4.2를 설치가 가능한지요?

2.1. 기존 GCC 4.1.0은 swinstall을 이용하여 설치되었기 때문에 이 경우 3.4.2는 configure 및 make 명령을 이용하여 설치하여야 되겠지요?

2.2. 이렇게 두 가지 version을 한 system에 설치하였을 경우 문제가 되지은 않는지요?



3. 또 다른 시스템이 있는데, 3.4.3 및 3.4.2의 차이는 무시해도 될 정도인지요?



미리 감사 드립니다.
3 응답 3
양계전
초등학생

GCC 두가지 version 관련

안녕하세요



1번은 확실하진 않지만 사용은 가능할것입니다..



2번은 4.1.0에서 3.4.2로 버전을 낮추신다는 이야기인데..



4.1.0 을 지우시고 3.4.2를 설치하시면 되겠습니다.



다운로드 경로는



http://mirrors.develooper.com/hpux/downloads.html



3. 3.4.3과 3.4.2는 거의 차이가 없는걸로 알고있습니다





답변이 도움이 되었으면 합니다 ^^
장준학
비정기 기여자

GCC 두가지 version 관련

감사합니다.



그런데, 문제는 4.1.0이 설치되어 있는 상태에서 3.4.2를 설치하여야 한다는 것입니다.



게다가 4.1.0이 /usr/local에 설치되어 있습니다. 듣기로는 4.x는 /usr/local 대신 다른 경로에 설치한다고 알고 있는데 여기에 설치되어 있군요.
양계전
초등학생

GCC 두가지 version 관련

제가알려드린 싸이트에 있는 gcc들은 모두 binary 형식으로 되어있기 때문에 swinstall 로 설치를 하지 않아도 됩니다



압축만 풀면 실행이 바로 될것입니다



아래의 예를 확인하세요



root:/b]swlist |grep -i gcc

gcc 4.1.1 gcc

libgcc 4.1.1 libgcc

root:/b]gcc -v

Using built-in specs.

Target: hppa2.0w-hp-hpux11.11

Configured with: ../gcc/configure

Thread model: posix

gcc version 4.1.1

root:/b]whereis gcc

gcc: /usr/local/bin/gcc /usr/local/lib/gcc /usr/local/man/man1/gcc.1

root:/b]pwd

/b

root:/b]ls -al

total 59264

drwxrwxrwx 2 root sys 96 Apr 17 11:44 .

drwxr-xr-x 40 root root 8192 Apr 17 11:42 ..

-rw-r----- 1 root sys 30327739 Apr 17 11:44 gcc-3.3.1-64-11.11-elf64.tbz

root:/b]bzip2 -d gcc-3.3.1-64-11.11-elf64.tbz

root:/b]ls

gcc-3.3.1-64-11.11-elf64.tar

root:/b]tar xvf gcc-3.3.1-64-11.11-elf64.tar

생략

root:/b]pwd

/b

root:/b]ls

gcc-3.3.1-64-11.11-elf64.tar pa20_64

root:/b]cd pa20_64

root:/b/pa20_64]cd bin

root:/b/pa20_64/bin]./gcc -v

Reading specs from ./../lib/gcc-lib/hppa64-hp-hpux11.11/3.3.1/specs

Configured with: ../src/configure --enable-languages=c,c++ --prefix=/usr/local/pa20_64 --with-local-prefix=/usr/local/pa20_64 --with-gnu-as --with-as=/usr/local/pa20_64/bin/as --with-gnu-ld --with-ld=/usr/local/pa20_64/bin/ld --disable-shared --disable-nls --host=hppa64-hp-hpux11.11

Thread model: single

gcc version 3.3.1

root:/b/pa20_64/bin]



이렇게 해서 쓰시면 되시지 않을까요?