HP-UX

apache , mysql , php 설치 문제

 
김용경
비정기 기여자

apache , mysql , php 설치 문제

ia64 hp server BL860c - os 11.23



mysql - mysql-5.0.51a-hpux11.23-ia64-64bit.depot



설치후

apache - 2.0.63 source 설치



설치후

php - 4.48 설치 error 발생

php - 5.2.2 설치 error 발생







php 설치시에 아무런 옵션을 주지않으면 설치는 되나 mysql과 연동이 안되는 문제때문에 mysql 과의 연동을 위하여 아래와같이 configure 함



./configure --prefix=/usr/local/php --with-zlib --with-zlib-dir=/usr/local/zlib --with-libxml-dir=/usr/local/include/libxml2 \

--with-mysqli=/usr/local/mysql/bin/mysql_config --with-apxs2=/opt/hpws/apache/bin/apxs





문제발생...........



php의 config.log 마지막줄에 아래와같은 문제 발생

...

.

.

..

ld: Can't find library or mismatched ABI for -lmysqlclient_r

..

.

.

/* Override any gcc2 internal prototype to avoid an error. */

/* We use char because int might match the return type of a gcc2

builtin and then its argument prototype would still apply. */



-----------------------------------------------

문제점 확인 php compile시 32bit로 작동되며 mysql은 이미 64bit로 설치 되어있는 문제 발견



mysql의 migration 작업이 이미 끝난 상태여서 건드릴 수 가 없는 상황.





웹서핑을 통하여 compile 할때 아래와같은 옵션을 export해서 써주면 된다는 문서를 얼핏 본기억이나 10분검색 ㅡ.ㅡ;





CFLAGS=+DD64 LDFLAGS=+DD64

CFLAGS=+DA2.0w LDFLAGS=+DA2.0w



결론은 compile 에러;;;

------------------------------------------

checking whether the C compiler (gcc +DD64 +DD64) works... no

configure: error: installation or configuration problem: C compiler cannot create executables.

------------------------------------------



어떻게 해야 하나요? ;;;;
3 응답 3
고재진
중학생

apache , mysql , php 설치 문제

안녕하세요..



open source로 구성하셔야 되는 이유가 없다면..



software.hp.com 으로 가셔서



apahce를 검색하시면 위에 sql, php 포함되어있는 소프트웨어를 다운 받으실수 있습니다.



그럼.
김용경
비정기 기여자

apache , mysql , php 설치 문제

고재진 / apache php tomcat webmin 은 있으나



mysql 과 연동된건 없던데요 ㅡ.ㅡㅠ
고재진
중학생

apache , mysql , php 설치 문제

안녕하세요.



물론 mysql 설치는 따로 하셔야 합니다.



/opt/hpws/apache/php/lib/php/extensions/mysql.sl 확인하시고



php.ini 에서 mysql관련 설정을 하세요.



그럼.