HP-UX

gcc 4.7.1 컴파일시 unistd.h 파일을 포함하면 에러가 발생합니다.

 
뜨는별
비정기 방문객

gcc 4.7.1 컴파일시 unistd.h 파일을 포함하면 에러가 발생합니다.

리눅스로에서 작업한 간단한 프로그램을 HP-UX에 포팅하려하는데 에러가 발생해서 골머리를 썩고 있습니다.

 

코드에 #include <unistd.h> 를 포함하면

 

sys/pset.h 파일에서 에러가 검출됩니다.

 

여기저기 찾아 보니 패치를 하라고 하시는데 백업 서버이기는 하나 몇몇 서비스가 운용되는 서버라 정확한 원인을 알지 못하고 아무 패치나 할 수 없는 상황입니다.

 

혹시 이런 경우에 패치를 해야하는 것인지 아니면 컴파일 옵션만으로 해결이 되는지 알고 싶습니다.

 

서버 정보 HP-UX 11.23, PA

 

고수분의 조언 하나가 사람을 살립니다 ~~