HP-UX

swinstall시 에러...

 
mark.M
임시 조언자

swinstall시 에러...

swinstall -s $PWD/aa.depot시 아래 에러가 발생합니다.



"host:/HP/depot aa.depot : An I/O error occurred while

performing this task."



위와 같은 샘 초기 화면에서 ok를 선택하고 들어가면

다시 아래와 같은 에러가 화면에 나타납니다.



"The default source "/HP/depot aa.depot" does not exist or is not

a vaild source adn there are no other registered depot on

host. You can type in the depot path on this or choose B dirrerent host ."
7 응답 7
jhpark
비정기 기여자

swinstall시 에러...

/usr/sbin/swagentd 요넘을 재시작 하시고 하면 되것 같은데요..
mark.M
임시 조언자

swinstall시 에러...

물론 에이전트를 재기동 했습니다.

그래도 결과는 같더군요 ^^;
이연주
정기 조언자

swinstall시 에러...

안녕하십니까.



# swlist -s $PWD/aa.depot



하시면 에러 없이 실행되는지 확인해보십시오. 에러가 안 난 다면그 다음에 다음 명령어로 depot등록을 해본신다음 swinstall를 해보십시오.



# swreg -l depot $PWD/aa.depot



# swinstall -s $PWD/aa.depot



그래도 에러가 난 다면 혹시 depot가 해당 os version과 맞는건지 확인해보십기 바랍니다.
mark.M
임시 조언자

swinstall시 에러...

역시 그래도 똑같은 에러가 발생하네요...

디팟이 다른 서버에서는 설치가 잘 되는데 이상하게 여기서만

문제가 발생하네요...에휴..



참고로 swlist -s $PWD/aa.depot 실행시



"ERROR: The INDEX file on the source did not exist or coult not

be read

ERROR host:/a.depot": An I/O error occurred while performing this takx"

같이 출력 됩니다.
이연주
정기 조언자

swinstall시 에러...

흠...그래도 에러가 나신다면 다음 방법을 이용해 보십시오.



# swinstall -s $PWD/aa.depot \*



Non interactive mode로 설치를 해보십시오.



그래도 에러가 난다면



depot가 제대로 설치된 서버를 가지고 network install을 한번 시도해 보십시오.

예를 들어 dpoet가 aa라는 host명을 가진 서버에 /HP 밑에 존재한다면



# swlist -s aa:/HP/aa.depot

# swinstall -s aa:/HP/aa.depot



김병수
본과생

swinstall시 에러...

이상하네요..

혹시 그러면



# file aa.depot

으로 file의 type을 확인하시고요..



# cksum aa.dpot



으로 file의 cksum를 확인하여 보시기 바랍니다.



그럼~~~
고광태
중학생

swinstall시 에러...

aa.depot 파일이 손상되어있을지도 모르니..



다른 depot 파일로 돌려보시게 좋을듯하네요..



잘돌아간다면 aa.depot 파일이 손상되었거나 depot 파일이 아닐수도 있습니다.



참고 하시길..