HP-UX

swinstall 시 error

 
lee_1
비정기 조언자

swinstall 시 error

There is currently no depot software on host "rp2470" at location /tmp/apache/depot". Make sure that an absolute pathname is specified for location (beginning with "/").



depot소스파일은 /tmp/apache 에있구요

swinstall -s $PWD/depot

수행했는데 에러가 나네요...

데몬 재시작했는데도...
9 응답 9
박영조
임시 조언자

swinstall 시 error

swinstall -s /tmp/apache/depot 이렇게 하면은 될텐데요... ^^;;
lee_1
비정기 조언자

swinstall 시 error

제가한거나 똑같은거라....



안되여 그것도..
kljang_1
조언자

swinstall 시 error

다른 depot을 swinstall 해보시고 같은 에러 메시지가 나온다면

/etc/hosts와 /etc/resolv.conf, /etc/nsswitch.conf 를 점검해보시는게 어떨까요?
lee_1
비정기 조언자

swinstall 시 error

아 그러네요...다른 depot도 같은증상으로 인하여 install이 안됩니다

/etc/hosts와 /etc/resolv.conf, /etc/nsswitch.conf 점검하라고 하셨는데...어떤부분을 점검해야할지.....자세히 알려주세요....감사합니다...
kljang_1
조언자

swinstall 시 error

/etc/hosts 에서는 시스템의 hostname과 localhost,loopback 확인하시고 /etc/nsswitch.conf 에서는 hosts: 라인에서 어떤것 부터 참조하는지.. 수정 가능하시면 hosts: files dns 하시고

/etc/resolv.conf는 위에서 작업한 경우 나누셔도 되고 nsswitch.conf

파일이 없다면 mv /etc/resolv.conf /etc/resolv.conf.org 하시고

swinstall 해보세요.

김춘수
유치원

swinstall 시 error

# swreg -l depot /tmp/apache/depot

# swinstall -s $PWD/depot



수행해 보세요~ ^^;

lee_1
비정기 조언자

swinstall 시 error

rp2470:/]swreg -l depot /tmp/apache/depot



======= 08/17/07 18:10:37 KST BEGIN swreg SESSION (non-interactive)



* Session started for user "root@rp2470".



* Beginning Selection

* Targets: rp2470

* Objects: /tmp/apache/depot

ERROR: There is currently no depot software on host "rp2470" at

location "/tmp/apache/depot". Make sure that an absolute

pathname is specified for location (beginning with "/").

ERROR: More information may be found in the daemon logfile on this

target (default location is spot:/var/adm/sw/swagentd.log).

* Selection had errors.







======= 08/17/07 18:10:37 KST END swreg SESSION (non-interactive)



수행했지만 안되네요 역시 같은에러로....
양계전
초등학생

swinstall 시 error

움..



/etc/hosts 와 /etc/rc.config.d/netconf 에 있는



hostname 과 설정되 ip 가 동일한지 확인 해보세요.



만약에 동일하지 않다면 동일하게 세팅후



/sbin/init.d/swagentd stop



/sbin/init.d/swagentd start



하시고 확인해보시길 바랍니다

Jungshik Yoo
임시 조언자

swinstall 시 error

저도 아는건 없지만 전에 비슷한경우 격은적이 있어서요



가장 기본적인 점인데..혹시 서버에 올리실때 어떤방법으로 올리셨는지



depot로 올리신건지 아니면 서버에서 압축풀고 depot를 만드신건지..



저두 전에 서버에 디스크용량이 부족으로 압축풀면 용량이안되서



depot로 만들어서 올린적이 있거든요..근데 역시나 안되거군요



아무리 아스키 바이너리 다 체크해도..^^



그냥 허접답변이였습니다.저도 비슷한경우 격은적이 있어서요



가장기본적인것이지만 다시한면 올려서 해보세요^^



감사합니다.