HPE 3PAR StoreServ Storage

3PAR File Persona NFSv4

Occasional Visitor

3PAR File Persona NFSv4


I am facing a problem with 3PAR File Persona. On the 3PAR side, NFSv4 domain name is set, and on the client the idmapd service is configured correctly. When i mount the file share on the client with NFSv4.0, the files owned by "root" user are displayed as "nobody", but the files owned by other users are displayed correctly. Looks like the "root" user is not getting mapped from 3PAR to client with NFSv4, but all other users are getting mapped. 

Can someone please suggest how to solve this issue.

File Persona version is 1.5.4, and the client is RHEL7.4. 

Thanks - Shashi Kanth. 


Re: 3PAR File Persona NFSv4

What exports-options are used at the FilePersona Server ?

Did you set "no_root_squash" ?

Can you provide the "showfshare nfs -d <nfs-share-name>" output, of the share that is been mounted?

Can you provide the "showfs -auth" output ?

Is the FilePersona node also bound to an Active Directory server ?




I am an HPE Employee

Accept or Kudo


Re: 3PAR File Persona NFSv4

Hi Shashi Kanth

Thank you for coming on HPE Community Forums,

I suggest you to kindly refer to the below mentioned links.




For further queries, I request you to get in touch with HPE Technical Support with the Serial Number and log a case., to get a solution on this.


Hope this helps!



I work for HPE

Accept or Kudo

[Any personal opinions expressed are mine, and not official statements on behalf of Hewlett Packard Enterprise]
Occasional Visitor

Re: 3PAR File Persona NFSv4

no_root_squash is set.

% showfs -auth
Auth Order: Local

% showfshare nfs -d ITOMShare
Share Name : ITOMShare
File Provisioning Group : advfs1
Virtual File Server : svnVFS1
File Store : HCMStore1
Share Directory : ITOMShare
Full Directory Path : /advfs1/svnVFS1/HCMStore1/ITOMShare
State : normal
Clients : *
Options : wdelay, rw, sec=sys, hide, no_all_squash, auth_nlm, sync, subtree_check, secure, crossmnt, no_root_squash
Comment : ---

-File access audit NFS options-
audit_close:off audit_open:off
audit_acl:off audit_meta:off
audit_read:off audit_write:off


Occasional Visitor

Re: 3PAR File Persona NFSv4

read all these documents, but did not found any clue. This is a very basic functionality what customers expects to work with any NAS solution.

Re: 3PAR File Persona NFSv4

The export information looks good. 

Are both NFS-client and the FilePersona server in the same NFSv4mapid-domain ?

This is a requirement for correct UID/GID mapping in NFSv4. If the server can´t match the user, it will automatically treat it as user nfsnobody.

At the cli, run "showfs -idmap".

If the output is "No NFSv4 domain is configured", then that´s most likly your problem.

To set/configure the domain in FilePersona run "setfs idmap <your-nfsv4-domain>

You can name the domain as whatever you want. e.g. "NFSv4.testdomain" or your DNS-domain.

The same setting need to be done at the NFSv4-client.

On a Linux system the configuration file is /etc/idmapd.conf.

The default NFSv4mapid-domain is usually the DNS-domain. If NFS-client and the FP-server are in the same DNS domain, then i recommend that you use this as your NFSv4mapid-domain. 

If client and server are in different DNS-domains, then you will need to set a uniq one, both at NFS client and NFS-server.

Note that you may need to restart/start the idmapd-service on the client, when changing the config.

If this does not fix the problem, then please engage your HPE-support. 

Hope that helps.




I am an HPE Employee

Accept or Kudo

Occasional Visitor

Re: 3PAR File Persona NFSv4

the domain is set correctly, on both File Persona and on the client.

except root user, every other normal users are getting mapped from File Persona to the NFSv4 client. The problem is only with the root user is not getting mapped for NFSv4 clients. 

% showfs -idmap
NFSv4 domain name: btp.swinfra.net

# grep Domain /etc/idmapd.conf
Domain = btp.swinfra.net





Re: 3PAR File Persona NFSv4

Since the setup seems to be correct, please open a support-ticket.

I am an HPE Employee

Accept or Kudo