HPE 3PAR StoreServ Storage

3Par 7400 failed disk replacement

 
RW41
Occasional Contributor

3Par 7400 failed disk replacement

Hello everyone. We have a client with a failed disk. The issue is the admin issued the servicemag start command but the tech didn't wait for it to complete before replacing it. Now we cannot move forward as we are very concerned about corruption though the client has not reported any issues. The original pdid is 154 and the relevant showpd output is below. The next showpd shows the replacement drive in 3 7 but no ID assigned.  I can get more info from the client if needed. Thanks in advance

3parcdlv01 cli% showpd -space 154

-----------------(MB)------------------

Id CagePos Type -State- Size Volume Spare Free Unavail Failed

154 3:7:0? FC failed 559104 0 0 0 0 559104

----------------------------------------------------------------

1 total 559104 0 0 0 0 559104

3parcdlv01 cli%

 

3parcdlv01 cli% showpd -state

Id CagePos Type -State- -------------------------Detailed_State------------------------- -SedState--

--- 3:7:0   FC   new     normal                                                           not_capable

5 REPLIES 5
Arun_KT
New Member

Re: 3Par 7400 failed disk replacement

Hi RW41, 

Let us check for the chunklets in the PD ID 151. Please share the output of the following commands:

showsys

showversion

showpd -c -p -cg 3 -mg 7

showpd -i -p -cg 3 -mg 7

servicemag status

Based on the outputs, I can help you to fix the issue.

Thanks and Regards,

Arun KT

RW41
Occasional Contributor

Re: 3Par 7400 failed disk replacement

Hello Arun_KT. Thanks for responding. The client has supplied the following.

3parcdlv01 cli% showsys

                                                               ----------------(

   ID ---Name--- ---Model---- -Serial- Nodes Master ClusterLED TotalCap AllocCap

24950 3parcdlv01 HP_3PAR 7400 1624950      2      0 n/a        95608832 78168064

3parcdlv01 cli% showversion

Release version 3.2.2 (MU4)

Patches:  P51,P56,P59,P84,P92,P94,P95

 

Component Name                   Version

CLI Server                       3.2.2 (P94)

CLI Client                       3.2.2

System Manager                   3.2.2 (P94)

Kernel                           3.2.2 (MU4)

TPD Kernel Code                  3.2.2 (P59)

TPD Kernel Patch                 3.2.2 (P94)

3parcdlv01 cli% showpd -c -p -cg 3 -mg 7

                              ------- Normal Chunklets -------- ---- Spare Chunk

                              - Used - -------- Unused -------- - Used - ---- Un

Id CagePos Type State  Total OK  Fail Free Uninit Unavail Fail OK  Fail Free Un

63 3:7:0   FC   normal   408  0     0    0      0     408    0  0     0    0

154 3:7:0?  FC   failed   546  0     0    0      0     378  150  0     0    0

--------------------------------------------------------------------------------

  2 total                 954  0     0    0      0     786  150  0     0    0

3parcdlv01 cli% showpd -i -p -cg 3 -mg 7

Id CagePos State  ----Node_WWN---- --MFR-- -----Model------ -Serial- -FW_Rev- P

63 3:7:0   normal 5000CCA06F09A59B HITACHI HCBRE0450GBAS10K W6G59GJG 3P02     S

154 3:7:0?  failed 5000C500982B5F98 SEAGATE STHB0600S5xeN010 S42237BS 3P02     S

--------------------------------------------------------------------------------

  2 total

3parcdlv01 cli% servicemag status

Cage 3, magazine 7:

A servicemag start command failed on this magazine.

The command completed at Mon Jul 13 16:33:20 2020.

Failed -- -- Failed. Please run servicemag status -d for more detail

3parcdlv01 cli%

Re: 3Par 7400 failed disk replacement

@RW41 

1st of all please remove all serial numbers from your post. You can mask outputs and share with us again. Suggest you not to share serial numbers in public forum.

Coming to  issue, you have 600GB failed drive and it seems you tried to replace with 450GB drive and that's why servicemag resume failed. You can check servicemag status -d command to see details

 

Hope this helps!
Regards
Subhajit

I am an HPE employee

If you feel this was helpful please click the KUDOS! thumb below!

***********************************************************************


I work for HPE
Accept or Kudo

Re: 3Par 7400 failed disk replacement

@RW41 

Can you please help us to understand if the issue got resolved or not?

If issue got resolved then how? This will help for everyone who are all following your forum.

Also request you to mark the forum as resolved if there is no more outstanding query from your end on this issue.

 

Hope this helps!
Regards
Subhajit

I am an HPE employee

If you feel this was helpful please click the KUDOS! thumb below!

*************************************************************************


I work for HPE
Accept or Kudo
RW41
Occasional Contributor

Re: 3Par 7400 failed disk replacement

Hello Subhajit, we have provided the client and technician with instructions to remove the 450GB disk and replace it with the correct 600GB disk. We sent a request for update last week and they have yet to do as we instructed and they did not explain the delay. I will update this thread as soon as the client carries out our instructions.

Thanks