HPE 3PAR StoreServ Storage

HTTP Error from server [500]

 
JackRafferty
Occasional Contributor

HTTP Error from server [500]

Hi,

updating my SP version from SP-5.0.0.0-22913 to SP-5.0.2.0-23974, once the image is loaded and i select update the following error message appears.. any idea's?

 

roblem accessing https://10.10.2.250:8443/servicesupport/REST/spservice/sp/upgrade

Occurred at 2018-06-20 12:37:05.496+0100

Plugin: ServiceSupport

Trace #0b5c24498907251fe2e2b0217bc60cde#

Reason: Internal Server Error

Caused by:
com.hp.tpd.sp.data.configuration.sp.SPInvalidSettingException: Transport agent is not set in SP.conf.
at com.hp.tpd.sp.data.configuration.sp.SPTransportAgentConfig.createAgentConfig(SPTransportAgentConfig.java:499)
at com.hp.tpd.sp.data.configuration.sp.SPTransportAgentConfig.getInstance(SPTransportAgentConfig.java:432)
at com.hp.tpd.sp.upgrade.SPUpgrader.calculateSpUpgradeSteps(SPUpgrader.java:316)
at com.hp.tpd.sp.upgrade.SPUpgrader.<init>(SPUpgrader.java:101)
at com.hp.tpd.sp.upgrade.SPUpgrader.newSpUpgrader(SPUpgrader.java:79)
at com.hp.tpd.sp.servicesupport.logic.sp.executors.SPUpgradeExec.<init>(SPUpgradeExec.java:69)
at com.hp.tpd.sp.servicesupport.logic.sp.ServiceProcessorLogicV1.spUpgradeAction(ServiceProcessorLogicV1.java:334)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:497)
at com.hp.tpd.share.ServerResource$2.lambda$invoke$2(ServerResource.java:409)
at com.hp.tpd.share.ServerResource$2$$Lambda$155/119934332.call(Unknown Source)
at com.hp.tpd.share.Metrics.time(Metrics.java:100)
at com.hp.tpd.share.ServerResource$2.invoke(ServerResource.java:407)
at com.sun.proxy.$Proxy176.spUpgradeAction(Unknown Source)
at com.hp.tpd.sp.servicesupport.web.v1.service.ServiceProcessorsRestV1.spUpgradeAction(ServiceProcessorsRestV1.java:2346)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:497)
at org.jboss.resteasy.core.MethodInjectorImpl.invoke(MethodInjectorImpl.java:139)
at org.jboss.resteasy.core.ResourceMethodInvoker.invokeOnTarget(ResourceMethodInvoker.java:295)
at org.jboss.resteasy.core.ResourceMethodInvoker.invoke(ResourceMethodInvoker.java:249)
at org.jboss.resteasy.core.ResourceMethodInvoker.invoke(ResourceMethodInvoker.java:236)
at org.jboss.resteasy.core.SynchronousDispatcher.invoke(SynchronousDispatcher.java:402)
at org.jboss.resteasy.core.SynchronousDispatcher.invoke(SynchronousDispatcher.java:209)
at org.jboss.resteasy.plugins.server.servlet.ServletContainerDispatcher.service(ServletContainerDispatcher.java:221)
at org.jboss.resteasy.plugins.server.servlet.HttpServletDispatcher.service(HttpServletDispatcher.java:56)
at org.jboss.resteasy.plugins.server.servlet.HttpServletDispatcher.service(HttpServletDispatcher.java:51)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:845)
at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1689)
at com.hp.tpd.share.TransactionFilter.doFilterChain(TransactionFilter.java:377)
at com.hp.tpd.share.TransactionFilter.doFilter(TransactionFilter.java:296)
at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1676)
at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:581)
at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:143)
at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:548)
at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:226)
at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1180)
at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:511)
at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:185)
at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1112)
at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:141)
at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:213)
at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:119)
at org.eclipse.jetty.server.handler.gzip.GzipHandler.handle(GzipHandler.java:395)
at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:134)
at org.eclipse.jetty.server.Server.handle(Server.java:523)
at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:320)
at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:251)
at org.eclipse.jetty.io.AbstractConnection$ReadCallback.succeeded(AbstractConnection.java:273)
at org.eclipse.jetty.io.FillInterest.fillable(FillInterest.java:95)
at org.eclipse.jetty.io.ssl.SslConnection.onFillable(SslConnection.java:202)
at org.eclipse.jetty.io.AbstractConnection$ReadCallback.succeeded(AbstractConnection.java:273)
at org.eclipse.jetty.io.FillInterest.fillable(FillInterest.java:95)
at org.eclipse.jetty.io.SelectChannelEndPoint$2.run(SelectChannelEndPoint.java:93)
at org.eclipse.jetty.util.thread.strategy.ExecuteProduceConsume.executeProduceConsume(ExecuteProduceConsume.java:303)
at org.eclipse.jetty.util.thread.strategy.ExecuteProduceConsume.produceConsume(ExecuteProduceConsume.java:148)
at org.eclipse.jetty.util.thread.strategy.ExecuteProduceConsume.run(ExecuteProduceConsume.java:136)
at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:671)
at org.eclipse.jetty.util.thread.QueuedThreadPool$2.run(QueuedThreadPool.java:589)
at java.lang.Thread.run(Thread.java:745)
Powered by Jetty://

1 REPLY 1
ASHOKA_Shankar
Advisor

Re: HTTP Error from server [500]

Try to upgrade the service processor with HPE support user login not with admin login.

Apart from that please check the prerequesites for the upgrade to 5.0.2.0 use the below link

https://support.hpe.com/hpsc/doc/public/display?docId=emr_na-a00002915fr_fr