HPE 3PAR StoreServ Storage

How to update SSMC from v3.2 to v3.8.2.1

 
SOLVED
Go to solution
daviddahles
Occasional Contributor

How to update SSMC from v3.2 to v3.8.2.1

Dear reader,

Currently I'm looking to update the SSMC to v3.8.2.1 due to the Log4j vulerability.
From the documentation i've read that you would be able to update/upgrade SSMC via the Administrator Console --> Actions --> Upgrade. Unfortunately, I don't see the this Upgrade optin

I think it has to as we are currently on a lower version than than 3.6. Looking at below article, you need a minimum of 3.6: Document - HPE SSMC 3.8 User Guide | HPE Support

How do you update to the latest version? Do we need to do this via an intermediate update and what is the best approach for this?

Thanks in advance

6 REPLIES 6

Re: How to update SSMC from v3.2 to v3.8.2.1

Is your current SSMC running on a windows system ?

How many arrays are currently connected to SSMC?

What 3PAR-OS version do the arrays have ?

I am an HPE Employee

Accept or Kudo

daviddahles
Occasional Contributor

Re: How to update SSMC from v3.2 to v3.8.2.1

Dear Betram,


- The current SSMC is running on Server 2012 R2
- What exactly Is meant by Array? I have one 3PAR with 2 controller nodes and 3 drive enclosures
- 3PAR-OS version is 3.2.2.612

I've read something that you need to use a migration tool?
Running this, will this affect anything on Production?


Solution

Re: How to update SSMC from v3.2 to v3.8.2.1

With the 3PAR-OS version 3.2.2 you are fine to move to SSMC 3.8.2.1. There are older 3PAR-os versions that are not supported. That´s why i asked.

About the update:

Starting with SSMC 3.4, SSMC switched to the appliance model.

You need to have a hyper-visor, like ESX-Vmware, or Microsoft Hyper-V.

You can either install/deploy the SSMC 3.8 VM from scratch followed by an upgrade to 3.8.2.1,

or you can use the migration tool to move from windows-based SSMC 3.2 to appliance-based SSMC 3.6 followed by an upgrade to 3.8.2.1.

If you decide to do the migration then please read section "Migrating from Installer-based SSMC deployment to SSMC appliance" of the SSMC 3.8 admin-manual. 

Since you have only one single array connected to SSMC, i recommend that you do a fresh install/deploy of SSMC 3.8 plus the upgrade to 3.8.2.1. You can keep the windows-based SSMC 3.2 running until your new 3.8.2.1 setup is ready.

Neither the migration, nor the new-install has an impact on the 3par-array. 

Hope that helps.

I am an HPE Employee

Accept or Kudo

daviddahles
Occasional Contributor

Re: How to update SSMC from v3.2 to v3.8.2.1

Though solved, I have one last question:
When installing/deploying a new SSMC applicance, do we have to look at any licensing regarding this appliance?

Much appreciated!

Re: How to update SSMC from v3.2 to v3.8.2.1

When installing/deploying a new SSMC applicance, do we have to look at any licensing regarding this appliance?

No. SSMC is completly free.

One additional comment:

If you decide to install a new SSMC-appliance and run the new appliance SSMC in parallel, then you should switch off the old SSMC after you have verified that the new one works.. 

It is not unusual to have multiple SSMC instances running. However each SSMC instance is adding some small load to the connected array(s) as it regulary queries the array for status information.

 

 

 

 

I am an HPE Employee

Accept or Kudo

daviddahles
Occasional Contributor

Re: How to update SSMC from v3.2 to v3.8.2.1

Dear Bertram,

I want to absolutelythank you for your in depth answers and swift replies!

Very much appreciated!