HPE 3PAR StoreServ Storage

SSMC Virtual Appliance deployment ssmcadmin password no longer working

 
SOLVED
Go to solution
Johannes_we
Frequent Advisor

SSMC Virtual Appliance deployment ssmcadmin password no longer working

Hi There,

today i migrated SSMC 3.3 to 3.4 in a vSphere VA. 
It is already migrated but now the ssmcadmin user password seems to have change.

My personal one was working before but it is no longer.
Is there a way to recover from this?

12 REPLIES 12
WSalvatore
New Member

Re: SSMC Virtual Appliance deployment ssmcadmin password no longer working

If this is on a windows host there are 2 ways.

1. Clear the password by executing the script ClearAdminCredential.bat located in the SSMC\ssmcbase folder. Run the script from an administrator command prompt window.

2. OR Remove SSMC from the VM you installed it and a new install will prompt you for a new username password … u will have to recreate the entry for 3par again … also cache the certificate

If it is not on a windows host, I am afraid I cannot help.

Sheldon Smith
HPE Pro

Re: SSMC Virtual Appliance deployment ssmcadmin password no longer working

As of version 3.4, SSMC is not something you install on a host; it's an appliance.

As noted in the SSMC 3.4 Administration Guide, if you need to reset the SSMC administrator account password use TUI [ the Text-based User Interface (TUI) ].


Note: While I am an HPE Employee, all of my comments (whether noted or not), are my own and are not any official representation of the company

Accept or Kudo

Johannes_we
Frequent Advisor
Solution

Re: SSMC Virtual Appliance deployment ssmcadmin password no longer working

Hi Sheldon,

as i said I´m unable to login to the VA anymore. I changed the password via TUI but after some time i´m unable to login at all.

UPDATE:
I tried it again after one day and it is working again so i´m thinking that there is any internal process using the old password. thus locking the account.

 

Re: SSMC Virtual Appliance deployment ssmcadmin password no longer working

Hello Johannes,

Good to see that you are again able to login.

Some clarification about the different types of logins related to SSMC and 3par. (for those who may hit similar problems)

 

A. When you first install SSMC 3.4, which is now an appliance, you will need to login as user "ssmcadmin" and forced to change the default password. This "ssmcadmin" user is for console-login-to-the-appliance, only. The login provides a small text-based menu to perform basic config, like networking, ntp, supportlog-collection etc... 

B. When you first connect to SSMC 3.4 via the web-browser (http://<ssmc-IP>:8443 ...) you wil be asked to define name and password of the "Administrator login". This login is different from the "ssmcadmin". With the "Administrator login", you can add and remove your 3PAR arrays to SSMC. 

C. After you have added your 3PAR(s), you login to SSMC as a user, that exists on the 3PAR. This user can either be pre-defined (e.g. 3paradm), or created at the array, or, if configured, an LDAP or AD-user.

So we have 3 different kind of logins related to SSMC/3PAR.

With the ssmcadmin user that you use to login into the ssmc-appliance you can do 2 things related to the logins and passwords:

1. You can change the ssmcadmin password.

2. You can Clear the "Administrator Credential". This will restart the SSMC-service and bring you back to item B)

 

 

I am an HPE Employee

Accept or Kudo

Paolo_c
Regular Advisor

Re: SSMC Virtual Appliance deployment ssmcadmin password no longer working

B. When you first connect to SSMC 3.4 via the web-browser (http://<ssmc-IP>:8443 ...) you wil be asked to define name and password of the "Administrator login". This login is different from the "ssmcadmin". With the "Administrator login", you can add and remove your 3PAR arrays to SSMC. 

With regards to option B above. After completing the initial configuration for SSMC 3.8.0 under remote console on the VM , I attempted login to https://10.xx.xx.xxx:8443 whereupon was prompted to enter a login to Administrator  (but dont recall seeing reference to defining name and password for Administrator login). Instead iof Administrator  just entered my ssmcadmin /password instead at which point i then received an invalid user (ssmcadmin) and password error. Is there anyway in which to reset /redefine the Administrator password (without blowing away the VM entirely ? .(If i click on forgot password i just get the message saying "Unable to send password reset email since SMTP is not configured"

 

Paolo_c
Regular Advisor

Re: SSMC Virtual Appliance deployment ssmcadmin password no longer working

2. You can Clear the "Administrator Credential". This will restart the SSMC-service and bring you back to item B)

How do i clear the administrator credential as cant see it listed as a menu option under config_appliance ?  (p.s I don't want to clear the ssmcadmin user login just the Administrator one so i can define and login to the gui https:\\10.xx.xx.xx:8443  as Administrator (with Administrator console)

Paolo_c
Regular Advisor

Re: SSMC Virtual Appliance deployment ssmcadmin password no longer working

looking at another post Solved: SSMC Admin password - Page 2 - Hewlett Packard Enterprise Community (hpe.com)

I see that after ssmc 3.6 ssmcadmin user account should also be used as the administrator console login ,,,so can login to the web console okay using ssmcadmin but if it try same user/password under administrator console access via the web gui https://10.xx.xx.xx:8443 i still get the same Invalid user (ssmcadmin) or password. message although also briefly see a pop up box with the message not secure before it disappears. ( I did add the full gui address above to my java whitelist on laptop) so wondering how to address this issue ?  

Re: SSMC Virtual Appliance deployment ssmcadmin password no longer working

After the 3.8 deployment, you will first need to login to the TUI as user "ssmcadmin".

TUI means, you need to open the VM-console, or, if your VM already got an IP-address you can ssh to it.

The first-TUI login, will ask you to change the password. Once you have done this and configured e.g. IP-address, timezone, DNS/ntp you can login via the web-frontend, the way you did already.

 

Hope that helps.

I am an HPE Employee

Accept or Kudo

Paolo_c
Regular Advisor

Re: SSMC Virtual Appliance deployment ssmcadmin password no longer working

Hi Yes i configured all of the menu options already using config_appliance....but when i connect to web gui using https:\\10.xx.xx.xx:8443 and enter ssmcadmin /xxxxx a small pop-up box appears with the words not secure and then get the error : Invalid user (ssmcadmin) or password (get the same error whether connecting under IE,Google Chrome and Edge) + had added IP to Java whitelist already.  I think that the issue could be related to the fact that i dont have a DNS entry setup for this server on the network + think i may need a certificate setup under csr which can bound to this name and should then (hopefully) allow me to connect . I should find out tomorrow but will update post accordingly