HPE 9000 and HPE e3000 Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot type into any console at # prompt

 
SOLVED
Go to solution

Cannot type into any console at # prompt

HP9000 L2000 HP_UX11
GSP and Secure Web Console will connect, login, respond to co to start a console and ^B to exit the console but does not echo or respond to any keypresses when at the # prompt.

Are these errors, seen on boot, relevant?

.profile[22]: tset: not found
.profile[26]: tabs: not found

The remote consoles did display the usual messages on both GSP and web consoles, even allowing me to switch into single user mode by interrupting the boot but now i'm at the # prompt anything I type does not appear on screen or get recognised by the server.

Any ideas why I cannot type at the # prompt?
3 REPLIES 3

Re: Cannot type into any console at # prompt

Further .. I have plugged in an ordinary console and that also fails to respond when in single user mode
(this time from init s)
.. This makes me think it is something to do with the the terminal settings rather than a GSP or Web console problem ... still investigating.
Bill Hassell
Honored Contributor
Solution

Re: Cannot type into any console at # prompt

.profile[22]: tset: not found
.profile[26]: tabs: not found

This is normal although sloppy...in single user mode, there are no filesystems mounted except / and /stand. Since tset and tabs are only fount in /usr/bin, you get the error. No problem though since these two commands do not affect the terminal's ability to communicate. If you see the boot messages and you can connect and interact with the GSP using CTRL-B, something is not healthy with the console in HP-UX. Check for a valid inittab

diff /etc/inittab /usr/newconfig/etc/inittab

Make sure all the special device files are present:

insf -e

Just a note about init and single user mode...it doesn't work as described. Rather than going into true single user mode (all filesystems unmounted, all processes terminated, all networking turned off, etc), init says something about:

INIT: New run level: S

INIT: SINGLE USER MODE

and leaves the console (and all other connections) running as before. None of the filesystems are unmounted and new telnet connections are accepted...

Check that someone did not change / or /dev permissions (755 is required).


Bill Hassell, sysadmin

Re: Cannot type into any console at # prompt

Bill,

The permissions on the GSP telnet devices were set to writeable only, as below.
I corrected the permissions per your post and can now init S or restart in single user mode and type subsequent commands.

There were also missing device files and a spurious extra line in inittab but nothing related to the 'cannot type' problem.

Problem solved: Thank you.

Having proved the 'cannot type' problem was not related to either remote console I will be discarding this OS and re-installing>

Most of the tty0p0 through tty1p1 were set to 'write only' (as below)
crw--w--w- 1 bin bin 1 0x000000 Jan 23 2003 tty0p0
crw--w--w- 1 bin bin 1 0x000100 Jan 23 2003 tty0p1
crw--w--w- 1 bin bin 1 0x000200 Jan 23 2003 tty0p2
crw-rw-rw- 1 root sys 1 0x010000 Oct 15 13:27 tty1p0
crw--w--w- 1 bin bin 1 0x010100 Jan 23 2003 tty1p1

Permissions and ownership corrected to
# ls -l tty?p?
crw-rw-rw- 1 bin bin 1 0x000000 Jan 23 2003 tty0p0
crw-rw-rw- 1 bin bin 1 0x000100 Jan 23 2003 tty0p1
crw-rw-rw- 1 bin bin 1 0x000200 Jan 23 2003 tty0p2
crw-rw-rw- 1 bin bin 1 0x010000 Oct 15 13:27 tty1p0
crw-rw-rw- 1 bin bin 1 0x010100 Jan 23 2003 tty1p1