HPE 9000 and HPE e3000 Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

Console gone on a HP9000/D380

 
Pedro Mansito
Occasional Advisor

Console gone on a HP9000/D380

Hi!
we have an old D-Class HP9000, a D380. The console is an HP 700/96. A few days ago, right after a reboot, the console ceased to work. We tested the console, same serial cable, with a FreeBSD box and it worked fine so we think the problem is on the serial port of the server. This is ioscan output:

H/W Path Class Description
==============================================
bc
8 bc I/O Adapter
8/0 bc Bus Converter
8/0/0 tty MUX
8/4 ext_bus GSC add-on Fast/Wide SCSI Interface
8/4.1 target
8/4.1.0 disk HP C3586A
8/4.5 target
8/4.5.0 disk SEAGATE ST34572WC
8/4.6 target
8/4.6.0 ctl Initiator
8/4.8 target
8/4.8.0 disk SEAGATE ST34572WC
8/4.9 target
8/4.9.0 disk SEAGATE ST34572WC
8/4.10 target
8/4.10.0 disk SEAGATE ST34371N
8/4.11 target
8/4.11.0 disk SEAGATE ST34572WC
8/8 ext_bus GSC add-on Fast/Wide SCSI Interface
8/8.0 target
8/8.0.0 disk HP C3586A
8/8.7 target
8/8.7.0 ctl Initiator
8/12 ba GSCtoPCI Bridge
8/12/1/0 lan HP J3515A HSC 10/100Base-TX D-Class 1 port
8/16 ba Core I/O Adapter
8/16/0 ext_bus Built-in Parallel Interface
8/16/5 ext_bus Built-in SCSI
8/16/5.0 target
8/16/5.0.0 tape HP C1537A
8/16/5.2 target
8/16/5.2.0 disk TOSHIBA CD-ROM XM-5701TA
8/16/5.7 target
8/16/5.7.0 ctl Initiator
8/16/6 lan Built-in LAN
8/16/7 ps2 Built-in Keyboard/Mouse
8/20 ba Core I/O Adapter
8/20/2 tty Built-in RS-232C
8/20/5 ba EISA Bus Adapter
10 bc I/O Adapter
32 processor Processor
49 memory Memory

Any ideas?.
6 REPLIES 6
Sanjay_6
Honored Contributor

Re: Console gone on a HP9000/D380

Hi,

Try resetting the console to the factury default.

Hope this helps.

Regds
Helen French
Honored Contributor

Re: Console gone on a HP9000/D380

Couple of things to try:

1) Check the terminal settings. Try 'hp' terminal emulation and set proper bit length and parity.

2) Check if any process is hanging on the console:

# ps -aef | grep console

3) Check the console connection on the server with another serial device (say serial printer or modem)
Life is a promise, fulfill it!
A. Clay Stephenson
Acclaimed Contributor

Re: Console gone on a HP9000/D380

If you are lucky then all that has happened is that the inittab settings have been clobbered. Do a stty -a < /dev/console. Are the values reasonable? If the command hangs (with a terminal connected) then you definitely have problems.
If it ain't broke, I can fix that.
Adisuria Wangsadinata_1
Honored Contributor

Re: Console gone on a HP9000/D380

Hi there,

You can try the following steps :
a. check the data cable & power cable

b. reset into factory default :
- power off the console
- press 'CTRL' and 'D' button at the same time, hold these and power on the console
- wait until you hear the beep sound
- release the 'CTRL' and 'D' button
- press 'enter' several times
- see if the console back to normal

c. kill the console process
# ps -ef |grep console
kill the console PID

Hope this information can help you.

Best Regards,
AW
now working, next not working ... that's unix
Pedro Mansito
Occasional Advisor

Re: Console gone on a HP9000/D380

Hi
i've reset the terminal but it didn't work. As I said earlier I connected the terminal to a FreeBSD system, using the same cable, and it worked fine.

stty output is

# stty -a < /dev/console
speed 9600 baud; line = 0;
rows = 0; columns = 0
min = 1; time = 0;
intr = DEL; quit = ^\; erase = ^H; kill = @
eof = ^A; eol = ^@; eol2 = ^@; swtch = ^@
stop = ^S; start = ^Q; susp ; dsusp
werase ; lnext
-parenb -parodd cs8 -cstopb hupcl cread clocal -loblk -crts
-ignbrk brkint ignpar -parmrk -inpck istrip -inlcr -igncr icrnl -iuclc
ixon ixany -ixoff -imaxbel -rtsxoff -ctsxon -ienqak
isig icanon -iexten -xcase echo -echoe echok -echonl -noflsh
-echoctl -echoprt -echoke -flusho -pendin
opost -olcuc onlcr -ocrnl -onocr -onlret -ofill -ofdel -tostop tab3

Best regards
dhananjay_1
Frequent Advisor

Re: Console gone on a HP9000/D380

Hi !

Can u please tell me what u have done for for this problem bcoz I am also facing the same problem on my D-class 350 server.


Regds
DJ