cancel
Showing results for 
Search instead for 
Did you mean: 

GSP

 
Saleelah Shabbar
Occasional Contributor

GSP

Trying to telnet into the gsp port, but I have forgotten the password. I have tried resetting the GSP from the command line, but this dosent work. I cant get to the system but not via the gsp.
5 REPLIES 5
Senthil Kumar .A_1
Honored Contributor

Re: GSP

hi,
first let us know which model of HPUX server u are talking about. You can get this info with "model" command.

In almost, all the server, u will find a small reset button on GSP card. Please reset the GSP using this button. Once done the GSP will be reset with the following.

IP - 192.0.0.192
Main user - Admin | passwprd - Admin
normal user - Oper | password - Oper

Let your effort be such, the very words to define it, by a layman - would sound like a "POETRY" ;)
Saleelah Shabbar
Occasional Contributor

Re: GSP

The model is an L class, I have tried running
stty +resetGSP < /dev/GSPdiag1 to reset the system from the command line, this comes up with GSP reset successfull, but the problem is we have forgotten the password so you can only get in as far as

Service Processor login:
Service Processor password:

I have tried the login and password you have supplied but this doesnt work either.

James Lynch
Valued Contributor

Re: GSP

Hitting the reset button will only cause the GSP reboot, it will not reset the login and password back to default.

Have you tried just hitting return at the login and password prompts?

If that does not work, it may be time to call HP support, they might have to send a CE out to resolve this.

-JL
Wild turkey surprise? I love wild turkey surprise!
Julian Perez_1
Valued Contributor

Re: GSP

I will re-check this issue, but I remember that only way to recover this failure in the past was updating GSP firmware to another version.

Regards,

Julian
Keep the faith
Matti_Kurkela
Honored Contributor

Re: GSP

If the GSP firmware is reasonably new, try this procedure:
1. Connect a serial console to the GSP's "Local" port.
2. Reset the GSP and watch the serial console display.
3. When the GSP is resetting, it will output a message containing the firmware version number on the serial console. The modern firmware versions will print something like "press 'p' on the local console to reset GSP passwords". The message will be visible for a short time only.

If the GSP firmware is older, you might be able to use the GSP's internal port from inside the system. Log in as root and use the attached script:
sh gsp-internal.sh install

After this, you'll be able to connect to a special port on the GSP with "cu -l/dev/tty1p0". When accessed in this way, the GSP won't ask for a password (some old firmware releases only). You can change the password and then remove the changes you made by using the attached script again:
sh gsp-internal.sh remove

If the GSP internal port sounds to you like a scary security hole, upgrade the GSP firmware: on later versions, this hole is plugged and the method to reset the passwords is the one I described first.

The attached script is created according to the instructions available in the GSP's HElp OVerview text, so I don't think it's very much of a secret.
MK