HPE 9000 and HPE e3000 Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

Gigabit card (A4929A) forced configured to 100-Base-TX speeds in HP-UX11i ver1

 
SOLVED
Go to solution
Anil Kumar_4
Occasional Contributor

Gigabit card (A4929A) forced configured to 100-Base-TX speeds in HP-UX11i ver1

What is the script(s) / commands to run in HP-UX11i ver 1 so that i can force configure the A4929A Gigabit Ethernet (copper) card to 100-Base-T (Fast Ethernet) speed ?

Pls note that i do not want Auto-Negotiation/ Auto-Speed .....thanks.
2 REPLIES 2
Fabio Ettore
Honored Contributor

Re: Gigabit card (A4929A) forced configured to 100-Base-TX speeds in HP-UX11i ver1

Hi,

# lanadmin -X 100HD 0
or
# lanadmin -X 100FD 0

where 0 is PPA by lanscan.

HTH.

Best regards,
Ettore
WISH? IMPROVEMENT!
Jeff Schussele
Honored Contributor
Solution

Re: Gigabit card (A4929A) forced configured to 100-Base-TX speeds in HP-UX11i ver1

Hi Anil,

Then to get this to survive boots you'll need to edit the conf file in /etc/rc.config.d - depending on driver in use
gelan => hpgelanconf (GigEther-00)
igelan => hpigelanconf (GigEther-01)
You can determine this from swlist | grep -i gig

Then set

HP_GELAN_INTERFACE_NAME=lan0
or
HP_IGELAN_INTERFACE_NAME=lan0

and

HP_GELAN_SPEED=100FD
or
HP_IGELAN_SPEED=100FD

and

HP_GELAN_AUTONEG=0
or
HP_IGELAN_AUTONEG=0

Of course, use the appropriate lanX for the NIC. If this is a newer system & card, I'd suspect that you're using the newer igelan driver.

HTH,
Jeff
PERSEVERANCE -- Remember, whatever does not kill you only makes you stronger!