HPE 9000 and HPE e3000 Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

HP terminal problem

 
Khairy
Esteemed Contributor

HP terminal problem

hi hpux guru,

I have a situation where i need to add a terminal.

The server is K220 and running hpux 10.20 (yeah, old box).

There server has a mux card (hp-ib) and its attached to this panel (P/N 5062-3054).

This panel has 8 ports (ports look like db25).

I then connect the 24542G serial cable (db9) to back of the terminal and db25 to the panel at port 0.

set terminal to communicate to port 2 (serial2).

WHen i run ioscan -funC mux, i can see 2 mux entries (mux0 and mux1) and with all the devices (/dev/diag/tty1p0, /dev/tty1p0 etc)

mux0 clearly indicate it comming from the built in and mux1 is the hpib device.

Then from sam, i add the terminal by choosing mux1 and port0. I set the baud rate to 9600.

Creation was successful and /dev/tty1p0 was created.

But there was nothing appear at the screen of the new terminal. I enter a few times but nothing appears.
I tried to change the baud settings on both terminal and tty settings in sam to 300 but it doesnt work too.

I then change the terminal to use port 1 on the panel and repeat the entire process. The creation was
successful. /dev/tty1p1 was created. But the terminal still doesnt show anything.

I check from `ps -ef | grep getty`, i saw 2 getty process is running for tty1p0 and tty1p1.

Can anyone help and shade some lights here. Does the panel support
terminal attachment? Or is it something else missing in the configuration?

Really appreciate anyone helps on this.
11 REPLIES 11
Ludovic Derlyn
Esteemed Contributor

Re: HP terminal problem

hi

Check if uour terminal is in mode connected( press F5 or F8 to check , i'm not sure of key sequence )

regards
L-DERLYN
Steven E. Protter
Exalted Contributor

Re: HP terminal problem

Shalom,

I suspect the multiplexor is malfunctioning.

tail -f /var/adm/syslog/syslog.log

Try a connect, through the device. I expect your will se nothing.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
TTr
Honored Contributor

Re: HP terminal problem

Try using a different serial port on the panel, try port 2 or 3. I vaguely remember something like ports 0,1,7 could not be used.
Khairy
Esteemed Contributor

Re: HP terminal problem

I've tried with other port 4 and still no luck. I assume this panel is supported to be use with terminals right? As i surf the net for more info, nothing much i could accept its known to be use for modem.

Can anyone who has experience long time ago with this setup share with me. Did i miss anything?

A. Clay Stephenson
Acclaimed Contributor

Re: HP terminal problem

Off the top of my head, ports 0, 1, and 7 are reserved. First make sure that the mux driver is in the kernel. Next make sure that there is a getty running on the port (ie there is is an inittab entry for the port that respawns getty). It's actually easier to use SAM to set up the ports on one of these things as it does all the steps for you.
If it ain't broke, I can fix that.
Dennis Handly
Acclaimed Contributor

Re: HP terminal problem

>I tried to change the baud settings on both terminal and tty settings in sam to 300 but it doesn't work too.

If this is a HP terminal, is REMOTE MODE set?
Khairy
Esteemed Contributor

Re: HP terminal problem

hi dennis,

yes, the terminal is set remote mode. I didnt change any settings except playing around with baud rate and set the terminal to use serial 2 (db9).

I've change the distribution panel with another unit but the results is the same. I add defination in /etc/ttytype accordingly (2392, same like /dev/console) but still no results. I play around with other values like 70096 or hpterm but still doesnt work.

I even change the 24542G cable but still cant get any login prompt. getty programs are all running for tty1p2,3,4,5 and 6. I've followed TTr and Clay advice by not attaching the serial cable to port 0,1 and 7 on the panel. I've rebooted the server but still the same.

I've tested all terminals by direct attach them to serial port (console) of K220 server and terminal has no problem of displaying the login prompt.

Is 24542G serial cable not meant for this kind of setup? 24542 cable is the standard serial cable comes with every HP terminal (in my case, terminal model is 70096).

Rgds
TTr
Honored Contributor

Re: HP terminal problem

I have the same panel on a K370 server but unfortunately that whole rack is turned off.
The cabling is as follows
1. server to MDP: 40299-60003
2. MDP 5062-3054
3. serial port cables: 17355D

The serial cables were connected to a model20 NIKE array and this was a perfectly working setup.

1. Do any of the lights on the MDP come on?
2. Clear all the old port configs and start fresh. Delete all the old getty's from /etc/inittab in case they prevent any of the new getty's binding to the ports.
Bill Hassell
Honored Contributor

Re: HP terminal problem

> I then connect the 24542G serial cable (db9) to back of the terminal and db25 to the panel at port 0...set terminal to communicate to port 2 (serial2).

I am going to assume that the terminal is a 700/94 or similar terminal. Since you said to connect to port 0 on the back but configure to use port 2 in the menus, I am not sure what the reasoning would be. Port 0 on all models of the 700/9x series is the primary serial port and the simplest way to setup the terminal is to turn power off, then hold down the "d" key and turn power on. Hold the "d" key down until you see the terminal reset message. This will select all the defaults and put the terminal in remote mode, port 0.

Then test to see if the terminal can show anything coming in from the computer with a script like this:

#!/usr/bin/sh
while :
do
echo Testing123
sleep 1
done

Make sure there is getty with 9600 baud running against the tty port, then run this script in the background, redirecting output to the mux port like this:

$ nohup testscript > /dev/tty1p1 &

If you want, you can start 8 copies with each copy redirecting to a different mux port. You can leave them running (no overhead to the system) indefinitely until you get something on the screen. The text will show up even if the port is not logged in (as long as getty has the port open).

You might also verify that the terminal is working by connecting a PC with a printer cable (serial 9pin to 25pin crossover). Run Hyperterminal, configure the correct COM port and set 9600 8N1 and you should see the test message.

I have a very hazy recollection that some mux products had a very non-standard pinout and looked like a modem rather than a computer. You might try a straight-thru cable (24542N or 24542M) cable, also known as a modem cable. Basically, the N-cable and G-cable swap transmit and receive (pins 2 and 3).


Bill Hassell, sysadmin
Khairy
Esteemed Contributor

Re: HP terminal problem

thanks guys for the responds. Sorry for the late reply.

I will try to get other serial cable and give it a last try. I hope i could solve this and assign points to all of u who has contributed so much in sorting out this prob.

Thanks again!
Khairy
Esteemed Contributor

Re: HP terminal problem

i will look for another serial cable and give it one more try.