HPE 9000 and HPE e3000 Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

HP9000 and HP-UX 11.0

 
SOLVED
Go to solution
Trojan36
Frequent Advisor

HP9000 and HP-UX 11.0

Anyone know the latest/newest PA-Risc server that can support HP-UX 11.0 in 32bits? Like to have a 4 processor server. I have a very old app that needs to run 11.0. Thx in advance.
6 REPLIES 6
Patrick Wallek
Honored Contributor

Re: HP9000 and HP-UX 11.0

None of the more modern servers will run HP-UX in 32-bit mode. All servers since about 1999 or 2000 are 64-bit only.

HOWEVER, a server that is running HP-UX 11.0 in 64-bit mode WILL RUN 32-bit code without a problem.

Depending on what you need, the rp24xx and rp54xx will run HP-UX 11.0.

You should also be aware that HP-UX 11.0 is NOT supported by HP any more. Support ended Dec. 31, 2006.
Patrick Wallek
Honored Contributor

Re: HP9000 and HP-UX 11.0

If you absolutely positively have to have 32-bit HP-UX 11.0, your options are:

a K-class - a K4xx or K5xx can have 4 to 6 CPUs of 180MHz or 240 MHz.

a D-class - a D380 is a 2-way 180MHz and a D390 is a 2-way 240 MHz.

an A180C - I think a max of 2 CPUs at 180 MHz.

All of these machines are getting quite old. The D380/390 and K5xx are scheduled to be desupported by HP the end of 2009.
Trojan36
Frequent Advisor

Re: HP9000 and HP-UX 11.0

Patrik,

Are there any documentation states that a server that is running HP-UX 11.0 in 64-bit mode WILL RUN 32-bit code without a problem?

This will solve half of the problem trying to get a servre that runs 32bit HP-UX. Thx
Highlighted

Re: HP9000 and HP-UX 11.0

Hi,

Its explicitly stated on p5 of the following doc:

http://docs.hp.com/en/938/iop.pdf

Give that this whitepaper is about application interoperability between 32-bit and 64-bit apps on the same 64-bit 11.00 system, the whole thing is implicit as well.

HTH

DUncan

Accept or Kudo
Trojan36
Frequent Advisor

Re: HP9000 and HP-UX 11.0

If I really want the 32bit version of 11.0. Can I choose to install the 32bit version of HP-UX during the install? The server I am targeting is the rp5470 server. Does any of the rp 5XXX server support 32bit OS? Thx in advance.
Patrick Wallek
Honored Contributor
Solution

Re: HP9000 and HP-UX 11.0

No, the rp5470 does NOT support a 32-bit OS. The server list I gave above (K's, D's and A180C) are the only remotely recent models that will support 32-bit HP-UX.

The rp24xx, rp34xx, rp44xx, rp54xx and rp74xx are all 64-bit ONLY machines.