HPE 9000 and HPE e3000 Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem installing PHSS_33890 on rp3410....

 
SOLVED
Go to solution
Chris Magargee_2
Frequent Advisor

Problem installing PHSS_33890 on rp3410....

I have a rp3410 running 11.11 with the following Firmware rev's:

MP FW : E.03.15
BMC FW : 03.50
System FW : 45.11

When I try to install PHSS_33890 (PDC45.44/BMC03.51/MPE.03.15) to upgrade the firmware, it fails to install with the following message, via swjob:

NOTE: This patch PHSS_33890 cannot be installed due to the version
of System's MP firmware () is less than E.02.29.
Please upgrade the MP firmware to E.02.29 before
installing this patch.

So how can E.03.15 be less E.02.29?

Thanks!
Chris
6 REPLIES 6
Torsten.
Acclaimed Contributor

Re: Problem installing PHSS_33890 on rp3410....

Hi,

I would expect at least an error message.

IMHO the "Note" is only to inform you - it's not an error.
Are there any more messages?

Also you should check this:

"If the currently installed MP firmware revision is
E.03.13 or later, the MP firmware update will fail
if the "Allow MP Firmware upgrade via PCI" option is
Disabled in the MP Security Options menu. To update
the firmware using this patch, enable this option in
the MP Security Options Menu.
" (from the install instructions)

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Chris Magargee_2
Frequent Advisor

Re: Problem installing PHSS_33890 on rp3410....

Thanks for the input! Unfortunately the "Allow MP Firmware upgrade via PCI" is enabled and the patch does not install even though it is just a "note" warning about the FW version.

Current Security Options:
L - Login Timeout in minutes : 1
N - Number of Password Faults allowed : 3
F - Allow MP Firmware upgrade via PCI : Enabled
R - Allow MP reset via IPMI : Enabled
P - Allow MP password reset via IPMI : Enabled

mits
Respected Contributor

Re: Problem installing PHSS_33890 on rp3410....

Patch special installation instruction says as follows.

10. The firmware update will be aborted if the currently installed MP firmware revision is less than E.02.29. In order to upgrade firmware using this patch first update the MP firmware to E.02.29 and then install this
patch.

Unfortunately, there is no 11.11 online MP firmware patch. You can update the MP firmware to E.02.29 with the FTP firmware patch.

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=15351&prodSeriesId=2512012&prodNameId=406773&swEnvOID=54&swLang=13&mode=2&taskId=135&swItem=ux-21688-1

* Have you checked the current MP firmware revision? MP:CM>SR
Sameer_Nirmal
Honored Contributor

Re: Problem installing PHSS_33890 on rp3410....

Looking at the current firmware rev's, it looks like the previous upgrade was done through OS patch.

I guess, wrong detection of MP firmware version is something should be looked into by HP support. Log a h/w call and see what's the problem.

However, you can try 2 alternatives to upgrade the firmwares.
1. Download the ISO Image of the firmwares through
http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=15351&prodSeriesId=2512012&swItem=PF-CSTORPDC4544&prodNameId=406773&swEnvOID=7&swLang=13&taskId=135&mode=4&idx=0

Upgrade the PDC and BMC firmware as iLO MP firmware is already updated currently. This gives you option to upgrade firmwares selectively.

1. Tweak setting Allow MP Firmware upgrade via PCI to "disabled" and then try to upgrade the remaining firmwares ( BMC & System ) through the patch. Here I am assuming the MP firmware version check would be bypassed and MP firmware upgrade will not be done which is not required in your case.
Julian Hall
Occasional Advisor
Solution

Re: Problem installing PHSS_33890 on rp3410....

You can get this symptom if the kernel does not have the IPMI driver installed.

If you add the IPMI driver with SAM and reboot, the firmware update should install without problems.
Chris Magargee_2
Frequent Advisor

Re: Problem installing PHSS_33890 on rp3410....

Thanks for everyone response! As it turns out we did not have IPMI driver installed in the kernel. I did that and upgrade proceeded as it should.

Thanks Again!
Chris