HPE 9000 and HPE e3000 Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

RP5400 server - UPS R3000XR

 
SOLVED
Go to solution
Kurt Beyers.
Honored Contributor

RP5400 server - UPS R3000XR

Hi,

I've got a RP5400 server with HPUX11i as OS. An UPS R300XR has been connected, but I'm having trouble to get the UPS working.


I've installed the LanSafeIII Power Monitor software and configured it, however when I launch it I receive the warning: 'Communication Failure with UPS'. This is probably because the UPS device file I've specified isn't valid.

So how is the device file created or determined? Do you need the LanSafe software for the UPS or can you just configure the UPS in SAM? Any links to installation doucments for the UPS?

best regards,
Kurt
14 REPLIES 14
Dan Maul
Trusted Contributor

Re: RP5400 server - UPS R3000XR

Kurt,

You may want to view this link:

http://h18000.www1.hp.com/support/files/server/us/download/14901.html

Good Luck.
I always keep a supply of stimulant handy in case I see a snake--which I also keep handy.
Kurt Beyers.
Honored Contributor

Re: RP5400 server - UPS R3000XR

Dan,

I didn't find muxh usefull information in the Lansafe manual.

best regards,
Kurt
Dan Maul
Trusted Contributor

Re: RP5400 server - UPS R3000XR

Kurt,

Are you sure the R300XR can connect to your RP5400 server. I didn't it see it listed under supported systems. Thus my reason for sending the link. Maybe (I'm) over looking something...
I always keep a supply of stimulant handy in case I see a snake--which I also keep handy.
Kurt Beyers.
Honored Contributor

Re: RP5400 server - UPS R3000XR

Dan,

yes the R3000XR is an UPS for PA-RISC architecture as well. See http://h30140.www3.hp.com/page/hp_power_protection.html

best regards,
Kurt
Stefan Stechemesser
Honored Contributor

Re: RP5400 server - UPS R3000XR

Hi Kurt,

it may be that the UPS port of the rp5400 does not support the 19200 baud that is needed by this type of UPS. The very old rp54xx systems have rev A GSP with this limitations. The newer Rev B GSPs fully support the R3000XR.
You can check which revision you have in the following way:

1.) Connext to the Console of the Server
2.) Press CTRL-B to get to GSP mode. Login or press ENTER two times.
3.) at the GSP> promt enter "he"

Then note the "Firmware Revision" in the 2nd line. If it starts with A (f.e. A.01.09) then it is an old GSP, if it starts with B (f.e. B.02.17) then you have a new one.

What to do if you have an old one ?

The official solution is to obtain a Rev. B GSP, but I verified that it also works with the Rev. A GSP when using the remote modem port (not yet oficially supported).
To do that, try the following:
1.) disconnect UPS cable & modem cable
2.) t the GSP> prompt enter "er" and set the GSP remote modem port to "session" mode
3.) disable all getty programs in /etc/inittab that use port ttyd0p2 tty0p2 or cul0p2
4.) connect the cable to the "remote console" port (modem port) of the W-cable
5.) kill the ls3 process if still running
6.) reconfigure ls3 with /usr/ls3/install.ls3
7.) restart ls3 and check if everything is running fine (ls3con or ls3X).

I hope this helps

Stefan

Jeff Schussele
Honored Contributor

Re: RP5400 server - UPS R3000XR

Hi Kurt,

Do you have the console cable for that rp5400?
HP P/N A5191-63001
It's a three headed cable - DB25 on one end & 3 DB9 on the other. They're labeled console, UPS & remote.
Of course you'd use the UPS in this situation & the device would be either /dev/tty0p1, /dev/tty1p0, /dev/tty1p1 or /dev/tty1p2 but I'm not sure which.
We don't use single UPS in our datacenter as we have datacenter-wide UPS systems so I've never had to set one up.

HTH,
Jeff
PERSEVERANCE -- Remember, whatever does not kill you only makes you stronger!
Dan Maul
Trusted Contributor

Re: RP5400 server - UPS R3000XR

Kurt,

perhaps this may be helpful as well. http://forums1.itrc.hp.com/service/forums/bizsupport/questionanswer.do?threadId=329646

You'll want to follow Wiktor link as he was having the same problem.

Good Luck!
I always keep a supply of stimulant handy in case I see a snake--which I also keep handy.
Kurt Beyers.
Honored Contributor

Re: RP5400 server - UPS R3000XR

Jeff,

the cable connections to the UPS are correct. That shouldn't be the issue.

Stefan,

I think it is a revision B GSP (not at the customer site for the moment, that's why I 'think') , but I'll verify it of course. And update then the thread.

But you do not have to create the device file for the UPS yourself, it is created automatically and is either tty1p0, tty1p1 or tty1p2.

best regards,
Kurt
Stefan Stechemesser
Honored Contributor

Re: RP5400 server - UPS R3000XR

Hi Kurt
with the old rev. A GSP and the new rev. B Gsp with Firmware %3CB.02.14 the devicefiles are created automatically
tty0p0 - console
tty0p1 - UPS
tty0p2 - modem

But with rev. B Firmware B.02.14 or above the UPS port changes to tty0p3. This device file is NOT automatically installed during bootup unless you have installed the following patches:

11.00
Console Driver Patch [PHNE_27393/PACHRDME/English] (reboot!)
INSF Patch [PHCO_27370/PACHRDME/English]
11.11
Console Driver Patch [PHNE_26326/PACHRDME/English] (reboot!)
INSF Patch [PHCO_27243/PACHRDME/English]

best regards

Stefan
Kurt Beyers.
Honored Contributor

Re: RP5400 server - UPS R3000XR

A follow up of the problem.

The firmware revision of the GSP is B.02.20

The output of an ioscan -fnC tty is:

Class I H/W Path Driver S/W State H/W Type Description
==================================================================
tty 1 0/0/4/0 func0 CLAIMED INTERFACE PCI BaseSystem (103c128d)
tty 0 0/0/4/1 asio0 CLAIMED INTERFACE PCI Serial (103c1048)
/dev/GSPdiag1 /dev/tty0p0 /dev/tty0p4
/dev/diag/mux0 /dev/tty0p2
/dev/mux0 /dev/tty0p3



I ended up by removing the LANSafe software and configured the UPS from SAM using the /dev/tty0p3 device file. I've changed the entry in /etc/inittab to respawn the ups_mond daemon.

Now I end up with following message on the console:

Aug 9 10:19:08 server /usr/lbin/ups_mond[1554]: /usr/lbin/ups_mond: UPS Moni
tor daemon starting; using configuration file /etc/ups_conf
Aug 9 10:19:11 server /usr/lbin/ups_mond[1554]: /usr/lbin/ups_mond: UPS /dev/
tty0p3 read failed: File exists; Uninterruptable Power Supply has not been conne
cted correctly; loss of power would not be detectible
Aug 9 10:19:17 server /usr/lbin/ups_mond[1554]: /usr/lbin/ups_mond: UPS /dev/
tty0p3 read of status failed: File exists

The cable between the UPS and the server has the part number 201092-002. I've unscrewed it and tightened it agian, but the problem remains. I don't see any bended pins.

Is there still a misconfiguration somewhere or is the cable itself defect?

best regards,
Kurt



Kurt Beyers.
Honored Contributor

Re: RP5400 server - UPS R3000XR

Some extra information.

We still had a spare serial cable from the sale UPS connected to a Windows server and used this one as well.

The error messages remain the same however, but it excludes 'a defect' in the cable.

When you look in SAM at the details of the UPS port, it mentions a baud rate of 1200. In the LANSafe manual, a baud rate of 2400 is mentioned. So if the UPS speeks faster then the port can listen, you get a communication failure.

How do you change the baud rate of the /dev/tty0p3 port? I've found some threads about 'kermit' to do this, but didn't find a thread that discussed it all the way. Any howto's or good links here fore? Assuming that the baud rate difference is causing the issue. And that 'ups_mond' can control this UPS.

Many thanks in advance,

Kurt
Stefan Stechemesser
Honored Contributor
Solution

Re: RP5400 server - UPS R3000XR

Hi Kurt,

the ups_mond does not support this type of UPS. I would strongly recomend to disable it.
You must use the LanSafeIII software and it should work with this type B GSP.

Regarding your questions with the baud rate: the baud rate is normaly set by software. You can change the default speed with the stty command, but this may be overwritten again by the next software that is using the port.
For details see: "man stty" and much more detailed: "man modem".

Example (on a L3000):
# stty -a < /dev/tty0p3
speed 300 baud; line = 0;
rows = 0; columns = 0
min = 4; time = 0;
intr = DEL; quit = ^\; erase = #; kill = @
eof = ^D; eol = ^@; eol2 ; swtch
stop = ^S; start = ^Q; susp ; dsusp
werase ; lnext
-parenb -parodd cs8 -cstopb hupcl cread -clocal -loblk -crts
-ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr -icrnl -iuclc
-ixon -ixany -ixoff -imaxbel -rtsxoff -ctsxon -ienqak
-isig -icanon -iexten -xcase -echo -echoe -echok -echonl -noflsh
-echoctl -echoprt -echoke -flusho -pendin
-opost -olcuc -onlcr -ocrnl -onocr -onlret -ofill -ofdel -tostop

best regards

Stefan
Kurt Beyers.
Honored Contributor

Re: RP5400 server - UPS R3000XR

Stefan,

Ok, I've disabled the ups_mond again in the /etc/inittab and reinstalled the LanSafe software once more.

I did the same configuration as previously, but now the LANSafe software is working. I tested a power outage and the server was shutdown as configured in the LANSafe software. I don't get it why it is working now and didn't work the first time, but when things work you can stop asking yourself 'why' ;-)

Another question however. Suppose that there is a power outage during the night and the server is stopped by the UPS. After an hour, the power becomes normal again. Is it possible to start the server again automatically instead of starting it again manually in the morning? Where should it be configured or does this require extra hardware?

best regards,
Kurt
Kurt Beyers.
Honored Contributor

Re: RP5400 server - UPS R3000XR

The server comes up again when the power is restored by default. But I had to wait untill the 'time to shutdown the system' configured in the LANSafe software was over.

best regards,
Kurt