HPE 9000 and HPE e3000 Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

STM will not start

 
Dane Van Steenwyk
Frequent Advisor

STM will not start

Hi, I am having a problem with running stm now that I have connected my system to a network. Was working fine until I set up network config.

Here is what it is saying when I type STM at command prompt:

Unable to start STM User Interface
Failed to initialize the main window

Possible Causes:

Internal Application Error

Any ideas what is going on?? Any help would be much appreciated. Thanks.
18 REPLIES 18
James R. Ferguson
Acclaimed Contributor

Re: STM will not start

Hi Dane:

Try stopping and (re)starting:

# /sbin/init.d/diagnostic stop
# /sbin/init.d/diagnostic start

Afterwards, run your 'stm' session.

Regards!

...JRF...
Dane Van Steenwyk
Frequent Advisor

Re: STM will not start

Thanks for the reply. I tried that and still getting errors. It sounds like it is having problems connecting to host or something that networking may have messed with. Any other ideas??
James R. Ferguson
Acclaimed Contributor

Re: STM will not start

Hi Dane:

A crude fix should be to reboot now that you have configured (and cabled) your network.

Regards!

...JRF...
Dane Van Steenwyk
Frequent Advisor

Re: STM will not start

Hey James,

Thanks again for your help but it still is giving me the same error message when I type stm at command prompt. I also tried the above cammands you gave me after the reboot and still same error occurs.

What I did was completely reloaded my system with 11.11 which has STM on it. Then I used DHCP at the first boot when it asks you if you want to configure a network. That worked fine and I am able to ping out to other ip's. But then I try to type stm and this error started to occur. If I load the system and don't set up a network STM seems to work fine??

Any thoughts??
DCE
Honored Contributor

Re: STM will not start


Dane,

Sometimes stopping the stm processes with the stop command does not actually kill all of the processes. Do a ps -ef | grep stm after you stop stm to see if there any processes still out there - if there are - kill them, then try restarting stm.

hth
Dave
Dane Van Steenwyk
Frequent Advisor

Re: STM will not start

Hi Dave,

Thanks for your input but I tried that also and nothing seems to be working. I think it has something to do with the ip adresses because I have noticed on stm before that when you are using it it says the ip adress at the top of the window when using a graphics monitor.

Is there maybe some file that needs to be edited or maybe something in SAM that can fix it??

I am not too great at this OS stuff with commands so any help would be much appreciated. Thanks!!
DCE
Honored Contributor

Re: STM will not start


Dane, the simplest solution maay be to deinstall and reinstall stm. If you have a later version, this should not require a reboot.

When you added the networking, did you change the host name? STM seems to be very picky about that. You could try adding the old host name to /etc/hosts as an alias for the new name.

Other wise, her are some resources for you:
on the system itself

/usr/sbin/stm/Rel_NOTES.HWE
/usr/sbin/stm/Rel_NOTES.STM


For the latest and most complete information on STM and EMS
Hardware Event Monitors, see the Web page "Diagnostics":

http://docs.hp.com/hpux/diag/

At this site, you will find Overviews, Tutorials, Quick Reference Cards, Frequently Asked Questions (FAQs), and much other material.
Dane Van Steenwyk
Frequent Advisor

Re: STM will not start

Hey dave,

Thanks for all of your help. I have tried everything you have mentioned and have been reading all of the manuals. I just loaded this sytem with HP-UX 11.11 2004 and without the networking enabled everything works fine so something is getting changed when I reset the system for a new user and use DHCP. I never changed any names just selected yes to use DHCP and went on setting my host name to fti.

Another problem that seems to be dealing with the same issue is when I try to load commandviewSDM using swinstall it says:

Could not contact host "fti". Make sure the hostname is correct.

This seems to be the same type of problem that is going wrong with the STM. Lemme know what you think.

Thanks again!!
DCE
Honored Contributor

Re: STM will not start



Dane,

You may have to use a static IP address. The applications are probably doing a lookup against the /etc/hosts files to find the hostname/IP address. Since you are using DHCP, I am not sure wher the apps would get the IP address from..........
Dane Van Steenwyk
Frequent Advisor

Re: STM will not start

That sounds a lot more like where the problem is stemming from. I will get with my IT guy tomorrow and see what we can figure out. Again another area out of my league. Im just setting up a system for testing hardware and downloading patches so I wanted to get all this working on the same machine so I don't have to use one for ftp and one for testing. I will post what I find out tomorrow after I show my IT guy what you told me. Thanks again!!
Torsten.
Acclaimed Contributor

Re: STM will not start

If you have a server, you need to have a fixed IP.

A reason for your problem could be the name resolution. Check the result of

hostname

and the resolution

nslookup


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Dane Van Steenwyk
Frequent Advisor

Re: STM will not start

Hi Torsten,

Here are the resulst of those commands. I guess I don't know what to look for. It looks like the name server adress is wrong. Is there a way to change it??
Dane Van Steenwyk
Frequent Advisor

Re: STM will not start

Sorry I accidentally hit submit before attaching results. Here they are:
Bill Hassell
Honored Contributor

Re: STM will not start

Based on the nslookup results, you need to change the /etc/nsswitch.conf file to:

passwd: files
group: files
hosts: files [NOTFOUND=continue TRYAGAIN=continue] dns
networks: files
protocols: files
rpc: files
publickey: files
netgroup: files
automount: files
aliases: files
services: files

Now your /etc/hosts will be checked first, then DNS. The 2004 install is quite old so I would download the latest diagnostics package from:

http://h20293.www2.hp.com/portal/swdepot/displayInstallInfo.do?productNumber=B6191AAE

This should help get things working. Also, to eliminate complicated network issues with Xwindows, make sure DISPLAY is unset before running stm. It will default to the character mode version of stm. If this works, you'll need to get Xwindows working first.


Bill Hassell, sysadmin
Dane Van Steenwyk
Frequent Advisor

Re: STM will not start

Hi Bill,

Thanks for the input. I can't find that /etc/nsswitch.conf file but I found a /etc/nsswitch.files that looks like what you were telling me about. However, it will not let me edit it. Do I need to or is there any way to do that?? See attatchment.

Thanks again!!

Robert-Jan Goossens_1
Honored Contributor

Re: STM will not start

Hi Dane,

The nsswitch.files is just an example, copy the nsswitch.files to the nsswitch.conf and change the host line. Be sure to login as root.

# cp /etc/nsswitch.files /etc/nsswitch.files

hosts: files [NOTFOUND=continue TRYAGAIN=continue] dns

Regards,
Robert-Jan
Dane Van Steenwyk
Frequent Advisor

Re: STM will not start

Hi Robert,

Thanks for the reply. We are getting somewhere now. I can get into STM now after copying and changing the nsswitch.conf files but it says no system under the map. Here is what the UI Activity log says...

Any thoughts??
Dane Van Steenwyk
Frequent Advisor

Re: STM will not start

Hey guys,

Thank you all for your help!! I got it figured out. I just edited the /etc/nsswitch.conf file then stopped stm then restarted stm and all is GOOD!!

Thanks again for all the replies!!