HPE 9000 and HPE e3000 Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

Shutdown is bringing L class up in single user mode

 
SOLVED
Go to solution
Andrew Penning_1
Occasional Contributor

Shutdown is bringing L class up in single user mode

when I run the command -:
shutdown -r now
The system comes up in single user mode. I have checked the initdefault in /etc/initab and this is set to run level 3. The only way I can get to run level 3 by running init 3 at single user level.
6 REPLIES 6
Alastair Donaldson
Frequent Advisor
Solution

Re: Shutdown is bringing L class up in single user mode

Check that root has the default shell in /etc/passwd. If it has been changed you may experience problems. It should be /sbin/sh
Josiah Henline
Valued Contributor

Re: Shutdown is bringing L class up in single user mode

Make sure that "init:3:initdefault" is at the top of your /etc/inittab file. If it is there, the file my be corrupt. You can try to recreate it using the one in /usr/newconfig/etc/.

What messages are you receiving in /etc/rc.log? Can you paste any errors and the last few lines?

If at first you don't succeed, read the man page.
Josiah Henline
Valued Contributor

Re: Shutdown is bringing L class up in single user mode

Make sure that "init:3:initdefault:" is at the top of your /etc/inittab file. If it is there, the file my be corrupt. You can try to recreate it using the one in /usr/newconfig/etc/.

What messages are you receiving in /etc/rc.log? Can you paste any errors and the last few lines?

If at first you don't succeed, read the man page.
DCE
Honored Contributor

Re: Shutdown is bringing L class up in single user mode



This is a long shot -

What is the boot string in the lif area?

It should be either HPUX or HPUX -lq

If the root disk was mirrored, and you lost a mirror, ther would not be enough disks left in the vg to come up unless the -lq option was specified

You can test by interupting the boot process, entering bo pri to boot off of the primary disk, enter yes to interact with the ISL, and at the ISL prompt enter hpux -lq

another option is that the boot string has somehow been set to hpux -is

you can change the boot string with the mkboot command.......

HTH

Dave
Josiah Henline
Valued Contributor

Re: Shutdown is bringing L class up in single user mode

Dave has a good point. You can check the boot string with the lifcp command.

lifcp /dev/rdsk/cXtXdX:AUTO -

You might have an incorrect boot string on your boot disk.
If at first you don't succeed, read the man page.
Sandman!
Honored Contributor

Re: Shutdown is bringing L class up in single user mode

Is this a trusted system? Had the same problem a while ago and PHCO_32865 fixed it. Take a look at it and see if its relevant.

http://www2.itrc.hp.com/service/patch/patchDetail.do?patchid=PHCO_32865&sel={hpux:11.11,}&BC=main|search|

hope it helps!