HPE 9000 and HPE e3000 Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

UPS configuration on rp8400

 
Sanjiv Sharma_1
Honored Contributor

UPS configuration on rp8400

Hi,

I am configuring a HP PowerTrust II-LR UPS
A1356 3 KVA on rp8400.

I wanted to know what is the device file name of ups port.

# ps -ef | grep ups
root 3652 1 0 14:55:02 ? 0:00 /usr/lbin/ups_mond -f /etc/ups_conf -e ups_monchild

# cat /etc/ups_conf
# @(#)B.11.11_LR
shutdown_delay_mins:1
shutdown_timeout_mins:5
upstty:/dev/tty0p1 # Port 1 (second) on terminal mux 0 for UPS rs-232

It gives the error in syslog:
Nov 11 14:46:44 abc03 /usr/lbin/ups_mond[3600]: /usr/lbin/ups_mond: UPS /dev/tty0p1 read failed: File exists; Uninterruptable Power Supply has not been connected co
rrectly; loss of power would not be detectible

I am suspecting that the device file of ups port is incorrect.

Thanks,
Everything is possible
2 REPLIES 2
Sanjiv Sharma_1
Honored Contributor

Re: UPS configuration on rp8400

Hi,

I forgot to mention that rp8400 has only partition 0 in my system.

# iosan -fnC tty
abc03:[root] /> ioscan -fnC tty
Class I H/W Path Driver S/W State H/W Type Description
===================================================================
tty 1 0/0/0/0/0 func0 CLAIMED INTERFACE PCI BaseSystem (103c128d)
tty 0 0/0/0/0/1 asio0 CLAIMED INTERFACE PCI Serial (103c1048)
/dev/GSPdiag1 /dev/mux0 /dev/tty0p1
/dev/diag/mux0 /dev/tty0p0 /dev/tty0p2

I am also not able to communicate with the ups port (tty0p1 and tty0p2) with kermit.

Thanks,
Everything is possible
Michael Steele_2
Honored Contributor

Re: UPS configuration on rp8400

Here is a doc on PowerTrust UPS's. Although A1356 is not mention I think you may still be able to refer to it.

Did you uncomment the entries in /etc/inittab? For example:

ups :respawn:rtprio 0 /usr/lbin/ups_mond -f /etc/ups_conf

ttp1:2:respawn:/usr/sbin/getty -h tty0p1 9600

Your 'usr/sbin/ioscan -fun -C tty' should properly list the device file, as you've indicated.

Communication is via the 'ups_mond' daemon which use this port.

Check syslog.log and /etc/resmon/log/api.log for 'ups_mond' events and error messages.

Also refer to /etc/rc.log for start errors.

Here's the doc:

http://docs.hp.com/cgi-bin/fsearch/framedisplay?top=/hpux/onlinedocs/B2355-90675/B2355-90675_top.html&con=/hpux/onlinedocs/B2355-90675/00/00/57-con.html&toc=/hpux/onlinedocs/B2355-90675/00/00/57-toc.html&searchterms=A2997A&queryid=20031111-071350
Support Fatherhood - Stop Family Law