HPE 9000 and HPE e3000 Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to see ATAboy Luns

 
Damodaran NJ
Occasional Visitor

Unable to see ATAboy Luns

All,

I have the following problem:

I have two HP servers with the same OS/patch level installed with Tachyon TL/TS/XL2 fibre cards installed.They are accessing an NexSAN/ATAboy with Lun security enabled through a Qlogic switch.I have checked zoning and Lun masking and they appear to be identical on both the boxes. While server1 is able to see the Luns(3 of them), server2 is unable to see the Luns. Please see the following command outputs:

Server1(Working):

bash-3.00# swlist|grep -i fibre
FibrChanl-00 B.11.11.09 PCI/HSC FibreChannel;Supptd HW=A6684A,A6685A,A5158A,A6795A
bash-3.00# tdutil /dev/td2

Vendor ID is = 0x00103c
Device ID is = 0x001029
XL2 Chip Revision No is = 2.3
PCI Sub-system Vendor ID is = 0x00103c
PCI Sub-system ID is = 0x00128c
Topology = PTTOPT_FABRIC
Link Speed = 2Gb
Local N_Port_id is = 0x610200
N_Port Node World Wide Name = 0x50060b0000bd815b
N_Port Port World Wide Name = 0x50060b0000bd815a
Driver state = ONLINE
Hardware Path is = 1/0/0/0
Number of Assisted IOs = 6683957
Number of Active Login Sessions = 1
Dino Present on Card = NO
Maximum Frame Size = 2048
Driver Version = @(#) libtd.a HP Fibre Channel Tachyon TL/TS/XL2 Driver B.11.11.12 PATCH_11.11 (PHSS_31326) /ux/kern/kisu/TL/src/common/wsio/td_glue.c: Sep 5 2005, 10:14:40

bash-3.00# tdutil /dev/td2 get remote all

Target N_Port_id is = 0x610400
Target state = DVS_READY
Symbolic Name =
Port Type = N_PORT
SLER Capable (supports Retry & TRID) = NO
Target Port World Wide Name = 0x5000402002e009ee
Target Node World Wide Name = 0x2002000402e009ee

Common Service parameters (all values shown in hex):
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Version_Hi: 9 Version_Low: 9
BB_Credit: 3 Ciro: 1
Alt_BBcred: 1 Rxsz: 840
Conseq: ff RO_Bitmap: f
Resolution: 0 EDTOV(ms): 7d0

Vendor version (in hex) 0 0 0 0
-------------------------------------------------------------

bash-3.00#

Server2:

bash-3.00# swlist|grep -i fibre
FibrChanl-00 B.11.11.13 PCI/HSC FibreChannel;Supptd HW=A6684A,A6685A,A5158A,A6795A
FibrChanl-01 B.11.11.03 PCI-X FibreChannel;Supptd HW=A6826A,A9782A,A9784A
PHKL_34161 1.0 Fibre Channel Mass Storage Patch
bash-3.00# tdutil /dev/td0

Vendor ID is = 0x00103c
Device ID is = 0x001029
XL2 Chip Revision No is = 2.3
PCI Sub-system Vendor ID is = 0x00103c
PCI Sub-system ID is = 0x00128c
Topology = PTTOPT_FABRIC
Link Speed = 1Gb
Local N_Port_id is = 0x610500
N_Port Node World Wide Name = 0x50060b0000bd734b
N_Port Port World Wide Name = 0x50060b0000bd734a
Driver state = ONLINE
Hardware Path is = 0/3/1/0
Number of Assisted IOs = 0
Number of Active Login Sessions = 0
Dino Present on Card = NO
Maximum Frame Size = 2048
Driver Version = @(#) libtd.a HP Fibre Channel Tachyon TL/TS/XL2 Driver B.11.11.13 (AR0612) /ux/kern/kisu/TL/src/common/wsio/td_glue.c: Sep 15 2006, 18:35:32

bash-3.00# tdutil /dev/td0 get remote all
No device found.
bash-3.00#

Please note that I had a lot of trouble with this HBA in the first place. The host wouldn't boot up with the card installed and I had to update the patches and rebuild the kernel before the host would boot up with the card and claim it. Also, the 1Gbps speed that you see was suggested by NexSAN. Didn't work. Any comments/suggestions would be great.

Thanks,

Damodaran



2 REPLIES 2
Denver Osborn
Honored Contributor

Re: Unable to see ATAboy Luns

What's ioscan show for the non-working box?

ioscan -fnH 0/3/1/0

-denver
Damodaran NJ
Occasional Visitor

Re: Unable to see ATAboy Luns

Hi,

Here is teh requested output:

bash-3.00# ioscan -fnH 0/3/1/0
Class I H/W Path Driver S/W State H/W Type Description
===================================================================
fc 0 0/3/1/0 td CLAIMED INTERFACE HP Tachyon XL2 Fibre Channel Mass Storage Adapter
/dev/td0
fcp 0 0/3/1/0.97 fcp CLAIMED INTERFACE FCP Domain
bash-3.00#

Please let me know if you need anything more.

Thanks,

Damodaran.