HPE 9000 and HPE e3000 Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

Unrecognized Filesystem disk

 
Selvaraj
Advisor

Unrecognized Filesystem disk

Hello experts,

Good afternoon.

I have a problem in mounting non-root internal data disk which was unplugged from L3000 box1 to another L3000 box2. Root mirror disk was also unplugged in the similar fashion from the same L3000 box1 and plugged it in box2.

Everything performed online without bringing down the box1 (online task). Root disks are working great but non-root data disks were unable to mount in box2. I did "fsck" and activated that particular volume group named "vg_retro". But error message frustrates me as shown below:

============================================
fsck /dev/vg_retro/rlvol1
invalid super-block
vxfs fsck: cannot initialize aggregate
file system check failure, aborting ...

vgchange -a y vg_retro
Activated volume group
Volume group "vg_retro" has been successfully changed.

mount /dev/vg_retro/lvol1 /vg_retro
/dev/vg_retro/lvol1: unrecognized file system
mount /vg_retro
mount - not a valid vxfs file system
==============================================

I have tried vgexport and vgimport commands. But nothing works out. Can someone tell me what is the procedure to unplug root mirror and non-root mirror disks from box1 to box2 (both are L3000). I want to perform this task online only without disturbing the box1. Because box1 is a production node (cannot be shutdown) whereas box2 can shutdown.

Reference in detail,

Box1 contains 4 disks as described below:
=========================================
1. Root disk (not disturbed)
2. Root mirror disk (unplugged & plugged to box2 of root mirror slot)
3. Non-root data disk
4. Non-root data mirror disk (unplugged & plugged to box2 of non-root data mirror slot)

Box2:
=====
1. Root disk (reverse mirrored from root-mirror disk of box1)
2. Root-mirror disk (taken from box1)
3. Non-root data disk (reverse mirrored from non-root data mirror disk of box1)
4. Non-root data mirror disk (taken from box1)
==============================================

Thanks in advance,
Cheers.
You can do it man !
3 REPLIES 3
Saurav_1
Valued Contributor

Re: Unrecognized Filesystem disk

Hi,

This is the I will do it. on the 1st unix systems.
# vgexport -p -m /vg_retro.map /dev/vg_retro

ftp this /vg_retro.map file on 2nd system in binary mode.

2nd Node

# insf -H
or # insf -e simple.
# ll /dev/vg*/group*

to confirm the unique minor number for VG.
# mkdir /dev/vg_retro
# mknod /dev/vg_retro/group c 64 0x090000 comment #unique no.

# cd /

# vgimport -p -q n -m /vg_retro.map /dev/vg_retro

if no errors are generated then execute the same command without -p

# vgimport -q n -m /vg_retro.map /dev/vg_retro
qurum should not create a problem.
Now
# strings /etc/lvmtab #confirm the hdd entries

#vgchange -a y /de/vg_retro

# vgdisplay /dev/vg_retro
# lvdisplay -v /dev/vg_retro/*

it should show all the LVs.

now a command called
# fstyp /dev/vg_retro/rlvol1 this will tell the recognised filsystem type of the LV.

# mount -F vxfs /dev/vg_retro/lvol1 /vg_retro

HOPE U DID THE SAME, THIS SOLVES UR PROBLEM.
Pls do assign points if ur query is resolved.
correct me if i am wrong

Saurav.




Mark Grant
Honored Contributor

Re: Unrecognized Filesystem disk



I think what you are going to have to try is a vgscan. This will read each disk for logical volume information and try and re-construct it on your production box. Make a copy of /etc/lvmtab before hand though.

You haven't done a vgexport of these disks, presumabaly because you want to keep the volume group intact on the original box. It may be that fsck has already broken the logical volume but I doubt it.

If the vgscan doesn't work you might want to try putting the disk back in the original machine, getting it up and running again by starting again and re-creating the mirror copy on it, doing a vgexport -p -m mapfile which won't remove the volume group and then trying to vgimport it on the production box again.
Never preceed any demonstration with anything more predictive than "watch this"
Selvaraj
Advisor

Re: Unrecognized Filesystem disk


Thanks Saurav & Grant.. I haven't tried all your steps. Infact those steps are always right and acceptable. But my problem is
"Unrecognised filesystem" to non-root data disk and its super-block has been already broken. How to repair this?. I don't want to perform these tasks once again due to some other work. I will try this again later.

Thanks again... catch you guys later.

You can do it man !