HPE 9000 and HPE e3000 Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

Ux 11.00 on a D210

 
SOLVED
Go to solution
Jeroen Muurling
Occasional Visitor

Ux 11.00 on a D210

I have installed ux 11.00 on a D210 but I have some problems with the internal NIC.
Lanman says the card is up and running but when I want to configure is it will not work.
Can some1 help me ?
8 REPLIES 8
Thayanidhi
Honored Contributor

Re: Ux 11.00 on a D210

Hi.

Try # ifconfig lan0
If the it returns running..
check the internet services in /etc/inetd.conf
especially telnetd is enabled or not.

Check the you get responses from all of these.

#ping localhost

#ping

# ping `hostname`

If all are OK, try to ping from any system this host with .

TT
Attitude (not aptitude) determines altitude.
Jeroen Muurling
Occasional Visitor

Re: Ux 11.00 on a D210

I tried the ifconfig lan0 and it returns "no such interface"
Ping localhost works.

Maybe I am missing a driver for the build in lan ?
Thayanidhi
Honored Contributor

Re: Ux 11.00 on a D210

Hi,

Please post out put of

# ioscan -fnC lan
&
# lanscan

If "ifconfig lan0" returns "no such interface", then interface is not configured.
Drivers are selected and loaded automatically while loading the OS.
Are your patches are uptodate?

TT
Attitude (not aptitude) determines altitude.
Jeroen Muurling
Occasional Visitor

Re: Ux 11.00 on a D210

I found out what was wrong !!
It was something with the netmask.
I commented out the netmask in /etc/rc.config.d/netconf, rebooted the system and it looks that it is working now.

Can some1 tell me what I did wrong in the past ?

/etc/rc.config.d/netconf.

HOSTNAME="hpunix1"
OPERATING_SYSTEM=HP-UX
LOOPBACK_ADDRESS=127.0.0.1

INTERFACE_NAME[0]=lan0
IP_ADDRESS[0]=10.0.0.151
#SUBNET_MASK[0]=255.255.255.0
BROADCAST_ADDRESS[0]="10.0.0.255"
INTERFACE_STATE[0]="up"
DHCP_ENABLE[0]=0

GATED=0
GATED_ARGS=""

#
# Router Discover Protocol daemon configuration. See rdpd(1m)
#
# RDPD: Set to 1 to start rdpd daemon
#

RDPD=0

#
# Reverse ARP daemon configuration. See rarpd(1m)
#
# RARP: Set to 1 to start rarpd daemon
#

RARP=0

ROUTE_GATEWAY[0]=10.0.0.150
ROUTE_COUNT[0]=1
ROUTE_DESTINATION[0]=default
Thayanidhi
Honored Contributor
Solution

Re: Ux 11.00 on a D210

Hi,

The IP address and mask everything should be in double quotes (").

See out put from my system

# grep -v ^# /etc/rc.config.d/netconf

HOSTNAME="server1"
OPERATING_SYSTEM=HP-UX
LOOPBACK_ADDRESS=127.0.0.1

INTERFACE_NAME[0]="lan0"
IP_ADDRESS[0]="192.168.0.4"
SUBNET_MASK[0]="255.255.255.0"
BROADCAST_ADDRESS[0]=""
INTERFACE_STATE[0]=""
DHCP_ENABLE[0]=0

GATED=0
GATED_ARGS=""

RDPD=0

RARP=0

#

Possibly this is the reason.

TT
Attitude (not aptitude) determines altitude.
Jeroen Muurling
Occasional Visitor

Re: Ux 11.00 on a D210

I tried to use the " around the netmask but it didn't work. It works when I comment it out so it's resolved.
Bob_Vance
Esteemed Contributor

Re: Ux 11.00 on a D210

You do not need the double quotes in netconf unless the value being set has a blank in it -- it's just a normal shell variable definition.

Your problem has to do with non-CIDR (google it :) addressing. In classic, classful (non-CIDR) addressing, subnet 0 and -1 (all 1's ; e.g. ffff) are not allowed.

Your address, 10.0.0.1 255.255.255.0 has a classful network component value of "10" and a subnet component value of "0.0".

If you *really* want the network/subnet to be 10.0.0 (i.e., you've got other boxes on the network that already happily use it), you'll need to set CIDR addressing in hpux (i.e., don't check subnet value):

# ndd -get /dev/ip ip_check_subnet_addr
1
# ifconfig lan2 10.0.0.11 netmask 255.255.255.0
ifconfig: ioctl (SIOCSIFNETMASK): bad value

# ndd -set /dev/ip ip_check_subnet_addr 0
# ifconfig lan2 10.0.0.11 netmask 255.255.255.0
# ifconfig lan2
lan2: flags=843
inet 10.0.0.11 netmask ffffff00 broadcast 10.0.0.255

Note that using 'ndd' is not a permanent change and it will be lost after a reboot. Thus, you also have to put the above ndd config change into the file

/etc/rc.config.d/nddconf
.

Otherwise, you can simply use a non-zero subnet, as in:

.... ifconfig lan0 10.0.1.11 netmask 255.255.255.0



"The lyf so short, the craft so long to lerne." - Chaucer
Bill Hassell
Honored Contributor

Re: Ux 11.00 on a D210

Another note about ndd. It is indeed the tool to fix small subnet masks (and to disable gateway probes) but due to a number of bugs, you must install the latest patch for ndd or it will ignore the ndd config file: /etc/rc.config.d/nddconf. You can verify this by setting a parameter manually, then read the value back using ndd. Now make the changes in nddconf and use ndd's -c option to see if it works. If so, it will continue to work after a reboot.


Bill Hassell, sysadmin