HPE 9000 and HPE e3000 Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

Vclass server not communicating with B180 Test Station?

 
Chris Fadrowski
Super Advisor

Vclass server not communicating with B180 Test Station?

I have a Vclass 2500 running 11.0 hpux, and a B180 workstation attached for monitoring the V. A few days ago they stopped communicating. the B180 is reporting "0 nodes found"..

1. I checked all connections, all is to spec
2. All trancievers are green
3. i can ping mu-0000 from the B class (mu0000 being the V class
4. the NIC is found and claimed.

i am at a loss on what could be going on. Does anyone have any commands or tricks that i could try to figure out why the B doesn't see the V anymore?
10 REPLIES 10
Steven E. Protter
Exalted Contributor

Re: Vclass server not communicating with B180 Test Station?

Check /etc/rc.config.d/netconf

on both boxes

See if the ip address is the same. See if the netmask on the ip address is the same. The netmask being different would put the machines on different networks, making communication impossible.

Also, check:

lanadmin -x 0

replace zero with the actual lan number of the interface from lanscan

Everything should probably be 100 BaseT Full Duplex manual.

Check switches and firewalls for hardcoded settings that are not correct or compatible. I usually have to talk to my network department.

Check and if possible replace cabling in case someone has sucked you lan cable into a vacuum cleaner.

Please report back. I love mysteries and am still on the DL list with the flu.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Chris Fadrowski
Super Advisor

Re: Vclass server not communicating with B180 Test Station?

i have 3 NIC's on my Vclass. One of which is LAN3 which is 1000sx full duplex in my netconf file. I don't see any other nic's in my netconf file on the V class.

on the B180, i have ONE nic in netconf. It does have a different subnet mask then my NIC on the vclass. However, the NIC on the v class is my network NIC and should be a class B network. The network communication between the v and the B is on a private lan but i don't see any NIC for it on the V.

the lanadmin -x 0 doesn't work on the B class, it just takes me back to the prompt. (it is using lan0 as well)

am i missing something here? Not all that good with networking between these 2 devices.
Steve Post
Trusted Contributor

Re: Vclass server not communicating with B180 Test Station?

YES.
Same thing happened to me. There is a network connection between the B180 and V-class machine that is INDEPENDENT of the normal network connections. I bet THAT one is down. NOT the normal network.

There are 3 things that come out of that B180.
1. A serial cable that lets you have a console connection.
2. A network cable that lets you see the test station from other places (like a different box, or your pc).
3. A SECOND, network cable that is directly connect to a special spot on the V-class box. This connection for me is a BNC network.

I bet this third connection is the faulty one for you.
In my case, the AUI to BNC coverter on the back of my B180 was busted.
Chris Fadrowski
Super Advisor

Re: Vclass server not communicating with B180 Test Station?

acutally, i think it's the ECUB board. It's the board that is used to communicate with the B class.
Chris Fadrowski
Super Advisor

Re: Vclass server not communicating with B180 Test Station?

it turns out that the Bclass had to be unconfigured then configured again. The V didn't like it's MAC address. This is done thru right clicking on the desktop and going to "TS_Console root"

unconfig
then config.. it worked. Now my only problem is i can't get a terminal window to my v class from the B like i could before. Any ideas there? tty? etc.???
Steve Post
Trusted Contributor

Re: Vclass server not communicating with B180 Test Station?

I don't remember on to do this. (sorry)
I examined my test station.
I see I have
"/spp/etc/console -M localhost hw2a-0000" as a process.

I opened a new window and tried that. It started up that window that checks for the node being present. It didn't start the console. Of course, I still have MY console.

The TITLE of the window is sppconsole.
I would search on sppconsole.
Chris Fadrowski
Super Advisor

Re: Vclass server not communicating with B180 Test Station?

actually i have no problem getting the sppconsole. it's the console that emulates the V class i can't get.
Steve Post
Trusted Contributor

Re: Vclass server not communicating with B180 Test Station?

I found the manual online. It had enough info for me to GUESS at an answer for you.

From the station, click the mouse on an open part of the desktop.
You should get a menu.
One of the options should be V-Class Complex.
Under that, you have "console..." and "shells..."
Try console node/0 complex.

No good? Try shells: sppdsh, or ksh.

My "V-Class complex is listed as "V-class complex:hw2a". I tried console, then node/0. It just gave me the message window again (the one with the node is ok messages).
But I didn't get rid of my console window ahead of time.

If console-node0 doesn't work,
try that sppdsh or ksh.
Still no good?
Perhaps a simple reboot of that test station will set it up correctly.
Or perhaps you could look in /sbin/init.d to see what is run last during startup of the test station.

hope this helps....
steve
Chris Fadrowski
Super Advisor

Re: Vclass server not communicating with B180 Test Station?

actually i tried all of that already. It just spawns a session to the B180 and not the V class. I used to be able to spawn a connection to the V class.
Steve Post
Trusted Contributor

Re: Vclass server not communicating with B180 Test Station?

You tried the reboot?

I REMEMBER that "console->node0" brought up the console. But it didn't for me when I tried it this time. A GUESS to try would be to close the message window, then try console->node0 option. It can't hurt can it?

I'm not going to try. My test station is working fine.

steve