HPE 9000 and HPE e3000 Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

rp2470 & rp2430 console

 
SOLVED
Go to solution
Don Ward
Occasional Contributor

rp2470 & rp2430 console

I am having trouble with the console on both a 2470 and 2430 system. I was able to use hypertermial as my console on both systems without any problems for about 6 months, then suddenly they both stop working properly. I can see what's displayed on the console and I can use CTL-B to access the GSP and navigate within GSP fine. Once I get out of GSP I cannot key anything in. I tried Ctl-Ecf without success. I tried to reboot still did not work. Decided to use an HP 700/96 as the console connected to the "M" cable via HP Cable C-24540-80011-1 same results. Any ideas out there?

FYI - I know that it is the "M" cable because of the dark color as I believe the "W" cable is lighter in color. Part number is A6144-63001.

6 REPLIES 6
Torsten.
Acclaimed Contributor
Solution

Re: rp2470 & rp2430 console

Hi Don,

a reboot of the system doesn't affect the GSP. There are several methods to reset:

1. from OS
check:
stty +queryGSP if there is no "functional" message, reset:
stty +resetGSP
2. push button
3. power cycle

I prefer #1.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Don Ward
Occasional Contributor

Re: rp2470 & rp2430 console


Thanks that did it! I ended up doing the reset, even though the query responded with "functional" I still could not key anything in.
Nguyen Anh Tien
Honored Contributor

Re: rp2470 & rp2430 console

Hi DonWard
pls assign point for solutions
tienna
HP is simple
Stefan Stechemesser
Honored Contributor

Re: rp2470 & rp2430 console

Hi Don,

hm, the A6144-63001 M cable is for the "new" GSP ("he" on GSP shows firmware version beginning with "C").
With that GSP the "stty +resetGSP
Anyway, you said that everything was working fine for 6 month and you can use the GSP interface without problems.
It is also interesting that the same problem happens on both rp24x0 servers.

Did you change anything in the software configuration of the servers or of your laptop that could impact the serial console connection (firmware update patches etc.)?
What is the output of "ps -ef | grep console" on the servers (is a getty running ?)
Do you see any output on the console before the OS is booted ?
If you can enter the BCH menu after reboot: Is the console path correct ("pa"):
(0/0/4/0 for rev "A" GSP, 0/0/4/1 for rev "C" GSP) ?
What does "ioscan -fnkC tty" show ?

best regards

Stefan
Don Ward
Occasional Contributor

Re: rp2470 & rp2430 console

Stefan,

* (what firmware is displayed when you enter "he" on the GSP ?)

Both servers show the same infomation:

Hardware Revision A0 Firmware Revision C.02.14 Apr 14 2003,11:05:49

* Did you change anything in the software configuration of the servers or of your laptop that could impact the serial console connection (firmware update patches etc.)?


We were trying to get a modem to work on the 2430 (without success) but nothing that I know of was changed on the 2470. I did notice that this seemed happened to both servers within in a day of each other. I thought that to be strange.

* What is the output of "ps -ef | grep console" on the servers (is a getty running ?)

root 5932 1 0 08:12:18 console 0:00 /usr/sbin/getty console console

* Do you see any output on the console before the OS is booted ?

The console would always display information, so when we shutdown and/or restarted the servers we could see the progress on the console.

* If you can enter the BCH menu after reboot: Is the console path correct ("pa"):
(0/0/4/0 for rev "A" GSP, 0/0/4/1 for rev "C" GSP) ?

Sorry, not sure what this is.

* What does "ioscan -fnkC tty" show ?

Both servers show the same infomation:

# ioscan -fnkC tty
Class I H/W Path Driver S/W State H/W Type Description
==================================================================
tty 1 0/0/4/0 func0 CLAIMED INTERFACE PCI BaseSystem (103c128d)
tty 0 0/0/4/1 asio0 CLAIMED INTERFACE PCI Serial (103c1048)
/dev/GSPdiag1 /dev/tty0p0 /dev/tty0p4
/dev/diag/mux0 /dev/tty0p2 /dev/ttyd0p2
/dev/mux0 /dev/tty0p3

Hope this helps.
Stefan Stechemesser
Honored Contributor

Re: rp2470 & rp2430 console

Hi Don,

the firmware revision C.02.14 shows me that you run a new type of GSP with the correct cable A6144-63001.
The console getty is running fine and the ioscan output looks good.
You are right that it is very strange that the same problem happens since one day on two independent servers and if you only touched one of the two, then it is not very probable that this is a server problem.
If I understood correctly, you also already tried a GSP reset (GSP> xd, then "r").

You managed to get a modem running on one of the servers. Do you have similar problems when logging in via the modem on the GSP ("er", then set to GSP mode) ? If no, then I would still suspect a problem with the laptop or serial cable. If yes, then please check the console path in the following way:

1.) reboot the server
2.) after the selftest, stop the bootprocess during "press any key within 10 seconds ..."
You reach then the Boot Console Handler (BCH)
3.) type "path" to view primary and alternate bootpath, console path and keyboard path (only needed if VGA installed).
4.) if the console path is NOT 0/0/4/1, then set it to 0/0/4/1 with the command
pa con 0/0/4/1
5.) "reset" to make the new setting become actual

If this also does not help, then I could imagine a problem with the serial setup of your OS after the modem was configured.
Please check if the changes to /etc/gettydefs are OK (console getty unchanged) and if your modem getty is not running on the same serial line than the console (tty0p0).

I hope this helps

Stefan