HPE 9000 and HPE e3000 Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

rp2470 and PowerTrust II-LR 3.0kVA

 
Alessio_4
Occasional Contributor

rp2470 and PowerTrust II-LR 3.0kVA

Hi,

we are having problems in connecting our rp2470 with a PowerTrust UPS.
We plugged the cable shipped with ups to the UPS port of the W cable from the server.
We can see these devices as tty's:
/dev/tty0p0 (console) tty0p2,tty0p3,tty0p4.

We tried to use any of the above ports but we couldn't get any communication link with the ups.
Using tty0p2 we got: Error File exists, etc.
Using other ttys we do not have any messages back from UPS (should have some message, if I bilieve well).
We used kermit to do some troubleshooting, but we do not get any answer from ups at any speed.

We have the same problem with the same configuration at other 3 sites (this should exclude problems with cables, I hope)

Do you have any ideas about it?
Is there any kernel driver to enable to connect to ups?

thanks,
Alessio
4 REPLIES 4
Zygmunt Krawczyk
Honored Contributor

Re: rp2470 and PowerTrust II-LR 3.0kVA

Hi Alessio,

connect UPS serial cable to the port labeled UPS on the W cable. Next configure the upsd daemon using SAM.

Regards,
Zygmunt
Alessio_4
Occasional Contributor

Re: rp2470 and PowerTrust II-LR 3.0kVA

That's what we did, but unsuccesfully.

Bernhard Mueller
Honored Contributor

Re: rp2470 and PowerTrust II-LR 3.0kVA

Alessio,

check for latest mksf and asio patches. Apply them and recreate /dev/tty device files.

do you have all rp2470s? or other models as well? could be a GSP firmware problem also.

Regards,
Bernhard
Alessio_4
Occasional Contributor

Re: rp2470 and PowerTrust II-LR 3.0kVA

Hi Bernhard,

all rp2470s are patched with the latest patches available.
As to server model, we have this problem on rp2470 only.

Thanks,
Alessio