HPE 9000 and HPE e3000 Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

/usr/lib/dld.sl: Can't open shared library: /usr/local/lib/libiconv.sl

 
SOLVED
Go to solution
Barbara Kramer
Frequent Advisor

/usr/lib/dld.sl: Can't open shared library: /usr/local/lib/libiconv.sl

Hi,
just installed fetchmail and ripmime. When I enter fetchmail -h, I receive the statements:
# /usr/lib/dld.sl: Can't open shared library: /usr/local/lib/libiconv.sl
# /usr/lib/dld.sl: No such file or directory
# Abort(coredump)

/usr/lib/dld.sl is there with all rights, yet /usr/local/lib/libiconv.sl is nowhere to be found. Where can I download the necessary libs?
thanks for helping
Barbara
live is great !!
3 REPLIES 3
Stan Sieler
Respected Contributor
Solution

Re: /usr/lib/dld.sl: Can't open shared library: /usr/local/lib/libiconv.sl

Did you check that you have the
documented necessary prerequisites?

The page:
http://hpux.connect.org.uk/hppd/hpux/Networking/Mail/fetchmail-6.3.4/

lists:
bison flex gettext libgcc libiconv m4 openssl

as run-time dependencies.

You can probably get all of those things
at hpux.connect.org.uk (or a mirror).

Matti_Kurkela
Honored Contributor

Re: /usr/lib/dld.sl: Can't open shared library: /usr/local/lib/libiconv.sl

Note that the quality of dependency information at hpux.connect.org.uk and the mirrors is not always good. There often seems to be some confusion in run-time vs. compile-time dependencies.

In this case, I somewhat doubt whether fetchmail _really_ needs flex, bison and m4 as run-time dependencies, given that flex and bison are fundamentally compile-time tools and m4 is a macro processor used with GNU autoconf (another compile-time tool).

The gettext, libiconv and libgcc packages are a basic requirement for almost all GNU software, so they make sense as run-time dependencies. OpenSSL also makes sense, because fetchmail needs it to be able to access SSL/TLS-secured POP and IMAP servers.
MK
Barbara Kramer
Frequent Advisor

Re: /usr/lib/dld.sl: Can't open shared library: /usr/local/lib/libiconv.sl

Hi,
the help was great, I downloaded the libs and I am good to go ;-))
thanks again
Barbara
live is great !!